Saris M2 ERG Mode and Resistance not adjusting

Hello all,

I have some issues lately with the Saris M2 smart trainer. We bought it some weeks ago and use it with TrainerRoad without issues. We used a ANT+ dongle with the Desktop app on Windows 10. Worked like a charm. Then, we had to move it, so we unplugged the M2. When we started to train again this weekend, everything turn sour with this trainer.

First, the power read was just off the chart (like dropping the pedal half a turn with just the weight of the leg we topped 250-500 watts!). After some plug/replug/unplug/desinstall ANT+ drivers/reinstall ANT+ drivers/update trainer firmware/do a new calibration/forget device and reconnect… The power reading were not off the chart, but the ERG mode and Resistance mode are just not working within the TrainerRoad apps (both desktop Windows 10 with ANT+ and Android app with Bluetooth). ERG doesn’t adjust at all, or does it like a minutes or so after the supposed change in power. When using Resistance it just doesn’t change anything whether I set it at 0% or 100%… Change it two, three, four times and then oups it goes at what feel 100% (based on memory when it was working fine), but the slider is a 25% or 50%… Basically it’s all over the place!

I was questionning if it’s the M2 that is at fault, so I tested with Zwift (Desktop with ANT+) and the Saris app (Android, via Bluetooth). Both are able to adjust the resistance whether it is ERG or manual selection. And it changes in maybe 1 or 2 seconds. The conclusion is that it’s the TrainerRoad+Saris M2 that is at fault, whether it uses ANT+/Windows 10 or Bluetooth/Android.

Any idea what I could more to resolve this issue (that I didn’t already do)? We really want to keep TrainerRoad as it has a strong training plan!


I was wondering if anybody had something to help me on this?


Send this to the support box they’ll get get you fixed up but don’t monitor the forums

1 Like

My girlfriend has the same trainer and just developed a similar issue. ERG does not seem to work at all. The trainer seems to be stuck in some sort of resistance mode. It only wants to jump between 100-110 watts. I thought it was possibly Trainerroad at first but I also tried it on Zwift and it was not working at all with Zwift. It would pair and then when you tried to ride it just did nothing. This all happened after she moved the trainer from one room to another. It worked fine on Trainerroad before the move. I am going to contact Saris on Monday. The trainer is less than 2 months old.