Trainer stays in ERG-mode even though resistance mode on Trainerroad

Currently riding Lazy Mountain and got bored, decided to play with resistance mode. However, even though I switch to resistance, the trainer stays in ERG, but what feels like a slightly sloppier ERG. I’m using a Tacx NEO 1 OG. Any recommendations to fix this?

I’m using the desktop beta app on Windows

I’ve got 23 mins remaining on the ride, kudos if you help me within that window :wink:

After pressing ‘T’, try your left and right arrows that might force it to change the resistance manually.

After sliding the resistance the trainer changes from ERG to resistance every few seconds. This is odd!

Bizarre :exploding_head: Perhaps try support and see if they have an answer. Submit a request – TrainerRoad
FWIW, I use the windows beta app too but with an Elite Suito.

1 Like


Definitely. You can also email the team at Those issues can stem from any number of issues but the support folks are pros at isolating those issues!

1 Like

make sure you arent simultaneously paired to ant+ and bluetooth

That’s probably it!!! I’ll check in an hour or so.

edit: @ryanppax - you found the issue! Many thanks.

@IvyAudrain - suggestion for the developers: 1. Make it so that I can turn off bluetooth/ANT in the Trainerroad app, as it is right now, Trainerroad hogs both protocols. 2. Add a note about resistance issue when paired to both.

Glad it worked out! I had that same issue, and a handful of others on here. I’d hope that eventually there will be some warning against doing that.