Ride Processing

I have finished my ride over an hour ago and it’s still telling me that it’s processing the ride. Any ideas what is happening?

Oh yeah. That used to happen to me all the time. Sometimes the ride would go through almost instantly, sometimes it would take all night. I whined and complained for a long time. Eventually the support team fixed the problem. Who knows what they heck they did.

I think part of my problem…I was using the desktop app on a PC that was not windows 10…with an ANT+ dongle. Running TR on my phone seemed to work a lot better than the PC. Eventually I went to a new laptop using Bluetooth connectivity. Things got better.

I’m having the same problem at the moment. It’s been about 2 hours or so and its still trying to sync.

I run it from on my iPhone, but usually don’t have any issues. I wonder if there are server issues at the moment.

Edit: It’s now working - 5 min after I posted this!

I have a win10 laptop and ant+ dongles as well.
I have sent a request to support and I’ll wait to hear from them.

@brettmacca I was just reading @monts post about off-line TR & remembered something I do regularly that might be something you should do (but probably already are!): make sure to record your workouts on your GPS headunit as a back up. Back in the day there was a real chance my TR workout would never sync but I could always count on my GPS headunit data file for analysis!

But, anyhow, TR software is right as rain for me now. I don’t give it a second thought anymore. I’m quite confident they’ll fix your issue as well.

1 Like

I’m about ready to give up on TR. From reading the forum posts, this is an issue that’s been around for well over a year. I’m not going to bust my rear end on TR rides, only to find that they won’t be synced. Not happy.

I am usually running zwift as well as TR for the scenery etc so I always have that back up file. TR customer support are working with me to upload the other file.

Are your rides uploading to Strava and do you run another program behind TR?

No, they’re not uploading to Strava. They’re not even syncing to TR. So, the first time help desk uploaded it manually.

1 Like

I’m trying to manually upload a file from Thursday because it wouldn’t sync from Strava for some reason, but it seems to be stuck in a loop. I disconnected the sync and reconnected it and everything, but nothing worked. Sending in a support email now, so hopefully they can resolve it come Monday. Perhaps @Bryce has some insight as to why this is happening?

EDIT: It never showed confirmation that it uploaded after I manually imported it, but when I refreshed the calendar page, it now shows it on my profile. Still not sure why Strava didn’t sync with TR though.

I’d send an email to support@trainerroad.com. They’ve been very responsive when I’ve had problems.