ERG Mode no longer working?

Good afternoon,

I’m sure theres a million and one different threads relating to ERG issues but im unable to find one specific to my issue unfortunately.

Just had a week or so break from TR and for some reason, ERG Mode isnt working at all. I use a Tacx Flux S thats using the latest firmware and ERG is enabled in TR, but its just running as if ERG was off so the power im putting out is dependent on what gear im in or cadence im running at.

Ive had a few drop outs in the past so today ive moved my trainer into a secluded area and turned off any possible signal interruptions but still no luck, can anyone shed some light?

Thanks!

Did you check to ensure you don’t have resistance mode on instead? There is a hotkey to change it that you may have pressed by accident.

Do you have any other programs connected to the trainer that may be fighting for control?

As far as im aware its not connected to any other applications at the time.

It will sync to both Tacx and Tacx Utility if i have them open but i make sure that the only thing open is TR at the time of training.

It might be worth saying that when using ERG mode in Tacx’s own app, it works fine.

I would suggest submitting a ticket to the support team.

2 Likes

Yep, i have done so just waiting on a response. Thanks for your help nontheless.

I have had an issue with my Tacx Flux S as well. The ERG works fine until the last interval big interval like Mount Field or Holt Hill and when the interval ends to cool down it’s still trying to keep me at my tempo wattage. The speed sensor shows a dropout on my after ride upload to Strava and Garmin Connect as well. The firm ware is up to date per my phone app. Other than those few times, the trainer works great.

Try switching to Resistance mode and then back to Erg.

1 Like

@team_bunty Yeah i’ve tried that and all sorts.

It actually happened a couple of weeks ago momentarily during my final interval and i had to close everything down and resume workout for it to work properly again, however not even that is doing the trick this time round. I hope support can shine some light on the subject. :sweat_smile:

You haven’t mentioned so I assume you’re not using powermatch? That was causing issues for me I think.

That’s a classical sign of a disconnect. Are you using BLE or ANT+? What device are you running TR on?

Using a Samsung galaxy S9, can’t remember if I’ve been using Ant / BT up until now as never had any issues, both are available to connect though so I’ve tried both.

I’m using a WIndows PC with ANT+

In my experience using Win10, BLE has been more stable and free of disconnects. Also using Flux S.

I ran into the same kind of problem twice now on my last workouts - using a Tacx Flux trainer. Workouts go perfectly smooth but then during low power rest intervalls and cooldown, the trainer doesn’t reduce resistance (it’s in ERG mode). Even when I reduce cadence dramatically, my W output stays above 200 or so. I’m going to try and calibrate the trainer with the Tacx app before the next training. Also good to notice is that I run my Garmin Forerunner 945 in indoor cycling mode simultaneously to keep track of Training Effect.

Would be great to hear if/how other people’s issues were fixed and whether you think it could be due to my Garmin running at the same time. (I would find that strange because the rest of the workout all goes perfectly well!).

That’s a disconnect. The trainer is not receiving power set commands anymore, and just stays on the last one it received. What device are you running TR on, and how are you connected - ANT+ or BT?

Running TR on an iPhone XR which I believe uses BT. I also wear a Polar H10 that is connected to the iPhone and my Garmin.

Well, it does react in a way because the Cumberland training that I did has many different FTP intervalls and those I can easily meet and the trainer will adjust. Just not when I have a massive drop in Watts (rest intervall or cooldown).

Is the issue visible on every low-power interval? That would be more indicative of hitting the resistance floor of the trainer. Do you shift to the lowest gear during those rest intervals?

The problem occurred first in my second to last training Mount Field, which has 3 rest intervalls and then the cooldown. Interestingly enough, the problem only started at the last rest intervall and continued throughout the cooldown. Yesterday I did Cumberland and had the same problem upon cooldown. Note that the differences in FTP during Cumberland are very small, perhaps 20W, whereas with rest intervalls and cooldown you really go down 100+ Watts.

I’m not sure it’s visible to you but this is the Mount Field workout in question: https://www.trainerroad.com/app/career/vincentw/rides/93463800-mount-field

Edit: yes, I do shift to lower gears during rest.

The ride you linked is private.