New update for TrainerRoad MACOS ... stalled?

All week, everytime I open TR on my Mac I get an alert that an update, 2020.32.02, has been downloaded and will installed on exit. Apparently it is not installing on exit. I think the same thing happened a month or so ago on a previous update. Is there a way to force this update, other than just uninstalling the app and re-downloading?

Have you contacted support@trainerroad.com?
That is likely your best place to get a quick answer and help if needed.

I’d just download from here: https://www.trainerroad.com/download and install over the existing app.

thanks Chad. It’s not an urgent problem, it’s just a minor … I wouldn’t even call it an annoyance. So I thought maybe other forum members would like to see the solution if anyone else is seeing the same thing.

1 Like

Have you tried doing downloading and installing the latest? It will install over the existing TrainerRoad app and in the end give the same result as auto-updating.

A little story about broken auto-updating… At some point after Microsoft bought Skype, the auto-update feature stopped working in a similar manner as you describe for TrainerRoad. Probably because my user account does not have admin permission. So when Skype tells me an update is available and wants me to authorize the Helper app, I kill Skype, download the latest, and install over the existing Skype. Probably do that at least once a month.

1 Like