KICKR18 spindown errors - Wahoo cannot determine why speed is not displaying during spindown (SOLVED)

UPDATE from the OP: TR tech support reached out to me and gave the instructions to roll back the KICKR firmware so that it works again. I don’t know why the Wahoo CSR said rolling back firmware was not possible on the KICKR; it really makes me question their customer support going forward. But kudos to TR’s support team.

Anyway - back to training!


Hoping to get some insight from the rest of the TR universe.

I’ve had a KICKR18 since the pandemic started, but recently has been giving me some weird behavior after I updated the firmware. Since then, any attempt at spindowns in TR give me a black screen with no speed. I did bring this to the attention of Wahoo and the had me do some workouts/testing that showed weird speed readings and temperatures that were occurring (-500 degrees F being reported), their advanced spindown would auto-complete without pedaling. I got an email back saying it’s signal interference - not sure how that’s possible given no changes in the setup, no new routers, cell phones, etc. in the house AND my wife’s KICKR Core right next to it runs fine without the update. I feel like they basically told me to pound sand (rant over).

Has anyone else seen anything along these lines about no speed during sp[indown? Luckily I use a Quarq for power - but I’m concerned that power matching will be inaccurate for training. Or since I’m running Quarq it doesn’t make a difference and I’m should just let it go.

Thoughts?

Glad your issue is fixed. I had the -500F problem last week but a factory spin down seems to have fixed it.

1 Like

I tried to do that, but the spindown would never start - either it got stuck at the start OR is said it was complete without doing anything.

Glad I have the weekend to come up with an email back saying how dissasitified I am with them. It literally took 3 minutes to rollback the firmware vs. a week of trading emails full of “it’s signal interference. on your end”.

I’m having this same issue. Would you mind posting which version firmware you were running and how to perform the rollback?

1 Like

Hi nobes,

No problem. I rolled back from 3.5.1 to 3.4.71. Here’s the instructions for iOS (kudos to Michael R. at TR tech support for providing them).

IOS Steps

  1. Open the Wahoo Fitness app and go to settings.
  2. Click Sensors.
  3. Click On the device if it is saved, find a new sensor if it is not saved.
  4. Click on the Wahoo device when it appears and wait for it to connect.
  5. Click the grey device icon to the left of the “Wahoo KICKR” text at least 5 times to bring you to the firmware update screen.
  6. Click on the recommended update or the downgrade to the current update you are using.
  7. Once complete, go back to the sensors page, and save sensor to the proper profiles.

See the attached image for where to click on the Sensors screen.

Good luck and good training.

2 Likes

Thanks for the super clear instructions. I’ll try that and hopefully it works for me too.

Happy training!

1 Like

sigh, I totally fell for correlation equals causation. This happened right as I was starting AT, so I thought it was the new app update. I will go try to do this now. Thanks for posting!

1 Like

Issue solved by rolling back firmware :grinning:

1 Like

Glad to hear it worked. I should Wahoo’s support team here so they understand it’s not an isolated issue.

FWIW - We aren’t the only ones reporting this. I got this email from TrainerRoad today. If Wahoo won’t listen to its customers, hopefully, they’ll listen to an important partner.