Kickr v6 - no power data after brief coasting

Hi all!

I’ve been training for a few months with a Kickr v6 and in multiple occasions something strange and annoying happens: sometimes after a hard interval I coast for a few seconds to catch my breath, or when coasting to accomodate myself on the saddle, when I pedal again the Kickr doesn’t send any power data to TR and the resistance goes down. I see the power target but the power reads 0, everything else works fine: HR and cadence from a different sensor come through as usual. It’s not that the flywheel is spinning faster than I’m pedalling, I’ve even let the flywheel come to a stop before pedalling again but power does not come back.

Sometimes, the trainer comes back to life and starts sending power data after a few seconds, between 10 to 30, but in many occasions, I’d say 1 in every 5 sessions, I have to restart (by unplugging) the trainer for it to start sending power data again. As you can imagine this is quite frustrating.

My setup: TR on Mac, Kickr firmware up to date with power smoothing off, HR strap and Giant cadence sensor, all connected via Bluetooth. I haven’t bothered using DIRCON as it’s very unreliable.

Has anyone seen something similar? Any potential solution I can try?

Thanks in advance!

Hey there @Bertie!

Sorry to hear about your recent struggles with your workouts. :slightly_frowning_face:

I’ve done a little digging on the backend, and I’ve found what I think may be causing the issue!

In the ride logs, I’m seeing that every time you stop pedaling and subsequently the workout pauses, for whatever reason, your active speed/cadence source switches from your Wahoo KICKR to a Giant RideSense speed/cadence sensor magnet.

I think that this is simply a matter of signal interference, and I have a feeling that if you were to remove or disable the RideSense sensors from your bike, things would work much better.

Let me know your thoughts and what you find moving forward.

Just shout if I can help out some more! :blush:

I had issues with Kickr, similar, but not exactly the same as yours. I tried two things:

  1. Factory calibration. Even though latest kickrs are self-calibrating, there’s a way to do that through wahoo app. There’s some magic involved that requires you to tap a calibration screen 5 times for this “secret” functionality to come up on your screen. It’s documented somewhere deep in wahoo’s troubleshooting guidelines. That was helping me, but not for long and my problem would come back eventually.
  2. Go to your kickr settings in wahoo app and disable the feature called “Erg Mode Power Smoothing”. I tried that and my kickr never acted weird ever since.

Ditto above
It is annoying

Thanks Eddie.

I unpaired the Giant RS cadence sensor during my last session (Monterey) and the issue persisted, if you can, take a look at the 13 minute mark and you’ll see the drop.

Any other ideas of what might be going on?

I had the same thing happening on the v5, I ended up downgrading the firmware but I don’t know if that is possible with the v6 as I downgraded to before some of the v6 features were added to the v5

1 Like

A trick I found for kicking the power back in is to switch to level then back to erg.

1 Like

This is the answer

1 Like

One would think that if you spend 1000+ bucks in an indoor trainer there was no need to tinker with modes mid session… my previous 10 year old, cheap as chips, Tack trainer worked flawlessly, so I refuse to accept this behaviour as part of a normal, functioning product.

I’ll try a recalibration as recommended and try with some other apps to suss out who’s the culprit here, and hopefully report back.

1 Like

Hey @Bertie,

You shouldn’t need to switch modes in order to get things working properly.

Before recalibrating, I’d recommend power cycling your KICKR by unplugging it for at least 5 minutes before plugging it back in. I’d also then check the firmware for an update.

I’d also be curious to hear about how your trainer acts with another software, as you mentioned. I’ve looked into your ride log for Monterey and haven’t seen any issues from our end. Can you confirm that your speed/cadence sensors are disconnected from your device entirely and not just the TrainerRoad app?

If we end up getting too in the weeds with this one, it might be best to reach out to so that we can be sure to give your ticket as much attention as we can. I’d be happy to pick this up from there if you’d like. Otherwise, let me know what you find after these troubleshooting steps.

We’ll get this sorted out. :slightly_smiling_face:

1 Like

I found that if it’s a long pause ( dog barking at the door, needs to go out and do his business) I will get the lack of power reading from the kickr. If I remove the device (blue tooth mode) and re-add it, the power reading/control comes back. A short pause to pick up a dropped earbud will not cause mine to loose the erg power control.

Thanks @eddiegrinwald, I’ll do some testing and will report back/open a ticket with support.

1 Like