Issue with app not recognizing login info

Same, I get “unexpected error” when I try to log in on the MacOS app and my ride also didn’t sync anywhere.

(HugOps to the TrainerRoad folks dealing with an outage on a Friday evening :slightly_frowning_face:)

Same on iPhone (iOS and TR App both up to date)

Same here. Finished indoor ride, but app didn’t record it as completed and app errors out. Cannot log back into app on my phone (android). Tried resetting password thinking that was the app’s problem but didn’t make difference. Can log in fine to the site with the new password in Chrome and on PC, workout doesn’t show as show completed in calendar.

…did anyone contact support?

1 Like

I sent an email in


Same on my iphone. It is ruining my schedule today. So frustrating!

1 Like

Same – though not surprised given how glitchy and clumsy the PC app is as a whole.

It seems more likely some backend service serving all their clients is having a bad start to its weekend

1 Like


Never fun.


Sent an email.

1 Like

Just finished a two hour ride and crash-a-roo. The completed ride is not showing up on the web.

1 Like

Mine isn’t working on Android and my wife’s isn’t working on her iphone.

Same. Android and PC

Feeling for the SRE/DevOps teams right now - I know the feeling, never fun.

@NateP (cc @Jonathan since you run comms / marketing) One takeaway suggestion for next time that you can take into your incident post-mortem - and there is always a next time despite the best laid plans - is just do some light comms on your social platforms and the forum letting people know you acknowledge there’s an issue and you’re working on it. We’re over an hour in here and there’s no official update.

People would rather get bad news, i.e., “we don’t expect the platform to be back online tonight”, than be left in uncertainty.

I run SRE/DevOps teams as my day job, and I totally get when you’re knee deep in stack traces, database issues, and container/vm resources being redlined dealing with comms seems like a less important distraction compared to the “real work” of getting the platform back online … but it really does matter, and your users feel it.


“UNEXPECTED ERROR” after logon from Android


Same (Android) :frowning:

That’s the workout I’m trying to do tonight… wish I got it open quicker

1 Like

Got a message from someone on the TR team that they are aware of the issue.


First time I’ve had time and motivation to work out this week.

And this happens!

Edit: standing next to my bike dressed up and ready to go.

Same! Very frustrating given the monthly premium.
I had to use my garmin to train. Dark ages.

1 Like