Updated TR on Android, can't log in anymore

So today before I was going to start my workout I noticed there was an update available for TR so I went ahead and updated. After starting TR I found myself logged out and when trying to log in I simply get presented with “Something went wrong, please try again.”

I’ve tried clearing cache, I’ve tried uninstalling and reinstalling, same deal.

Down for me as well. Can’t log into iOS or OSX apps. Error messages each time.

Same for me, for both Android tablet and on Mac. error on startup. Seems TR is having an outage on their side.

It aint working for me neither. There’s always some issue or another. I don’t know why i bother updating the app as issues are frequent with the android app.

Its still laggy and i still get the “finishing install %” notification every time i start the app even after notifying support twice now and being assured its been worked on but alas no.

Same issue on IOS

Same here. Both IOS and Windows do not work.

Likewise on PC app. Just showing “Something went wrong” and a red screen. Frustrating. Have reported to Support…

I seem to be highlighting bugs all this last week or so.

Its has been lashing it down here the last 20 mins so I ditched the outside ride for inside… I wonder if I can use the outside ride I loaded inside???

1 Like

Alright, at least I don’t have to fret about me possibly being alone with this problem. Hopefully it’s fixed soon.

As a work around, one can mark the workout as ‘outside’ and then push it to Garmin.

And it is working again :slight_smile:

1 Like

I am now seeing the app and getting a download of an update. The question is, should I expect it to be stable enough for a workout now?

The app feels buggy to me.

Hey all,

Apologies for the issue that just popped up. Our devs hopped on it and the app should be back up and running again!

Feel free to let me or TR Support know if you have any other troubles.


This sort of thing seems to happen a lot.

Looks like it is working again.