iPhone XS running TrainerRoad does not connect to Wahoo Kickr2018?

I finally upgraded my iPhone from 6 to XS. However, after the upgrade, I could no longer get the TrainerRoad app or the Wahoo Fitness app to connect to the Kickr. On the WF app, I can see the Kickr, click on it and it just shows connecting… Never connects. On TR it never connects either. Tried rebooting, resetting, turning on and off things, etc. Initially thought my Kickr was broken but then tried my MacBook and that connected just fine.

Get my wife’s iPhone 8 and run the WF app and upgrade the Kickr firmware. After this, my iPhone XS can also connect to the Kickr properly again.

Hope that helps someone.

1 Like

Did you completely unpair/delete and start over again? Assuming you restored from an iCloud backup? When restoring to a new phone (XS) I had to re-pair my car, Garmin, and other BT devices, this does not carry over when restoring even though it shows them in the list.

1 Like

Yeah. unpaired everything, Even tried re-installing the Wahoo Fitness app. Nothing seemed to work. All other BlueTooth sensors just worked fine. It was only the Kickr that had the trouble and after the firmware upgrade, it also just worked first try.

For connection issues like this, our Support Team will be your best resource. They have a lot of experience with device-sensor interactions and they would be happy to help you get things sorted out.

You can reach them at support@trainerroad.com :slight_smile:


1 Like