Frustration WIth Wahoo App. Wahoo app recognize my Kickr Snap as Kickr causing issues

I didn’t ride my trainer for a week and suddenly there is this connection issue :cry:
what happened:

  1. At first Wahoo fitness app wasn’t able to connect to Kickr Snap at all
  2. I cleared all the cache and data of the app then tried to pair from start
  3. Now the app tells me that I need to update firmware (already did 2 months ago when I bought it), and I tried like 20 times it kept failing to update.
  4. Now I realize the app is mistakenly think my Kickr Snap is Kickr. Default name is Kickr and the icons are Kickr instead of Kickr Snap as I remember how it was.
  5. I also do not see any spin down button anymore.
  6. Now I checked my app history, I saw there was update 2 days ago. I wonder if this issue is related to this update.

Can anyone tell me the screenshot of my kickr snap on the app looks alright? I think if app recognize the trainer as Snap it should look different from that.

Finally, I love the trainer, but there has been too much frustration. Buggy software :cry:

This seems like a nice case for wahoo support :wink:

3 Likes

Wahoo support have only email channel now. It takes them a few days to reply each email. And first email they reply is always “hey did u check our online manual”. I guess i will have to be patient.

1 Like

One thing to try is restart your phone and then close all other apps before opening the Wahoo app. I don’t know about Android, but on iOS only one app can talk to a Bluetooth device at a time. Once an app connects to the trainer, I have to quit it so any other app can connect

1 Like