ERG Speed Sim keeps turning off (KICKR CORE)

I’m wondering if anyone here has this same issue, whenever I start my TR workouts, I need to enable the ERG speed SIM using the Wahoo app. Literally every single time. I have had the same trainer for roughly two years, no problems, except for now.

Do you know if TR app controls the setting? Sounds a bit unlikely to me. I think there hasn’t been any updates slash changes in kickr firmware, I’m trying to narrow down which change caused the issue. I’m using TR on Android, app version being 2030.3.0.92026, I suppose thats the latest (?) one. KICKR CORE Firmware is v1.0.13.

It’s a minor issue, which does not affect my training, it just messes up my stats.


Kickr 2017 and it doesn’t work reliably. Wahoo support told me it is only supported when using the Wahoo app. For awhile I would start Wahoo app, enable speed sim, quit Wahoo app, and then start TrainerRoad. Do not use TR to do a spindown calibration, that will disable speed sim.


Thanks bbarrera!

Update from my side. I think TR app doesn’t have anything to do with this. I can reproduce this without touching the TR app:

  1. Power on the Kickr core
  2. Open wahoo app
  3. Enable ERG speed sim
  4. Close app
  5. Power off Kickr core, wait 30 sec
  6. Power on the Kickr core
  7. Open wahoo app
  8. Check status of ERG speed sim (should be enabled, but it is not)

I have contacted Wahoo support but no proper answer yet. Lets see.

My current workaround is to enable the setting in Wahoo app, then open TR and do my workout. Easy to do, hard to remember :slight_smile:

1 Like

I hope you get a good reply from Wahoo!

I did. They said I don’t need that feature. This is getting a bit weird IMO :crazy_face:

1 Like

Eventually I gave up on Wahoo speed sim and the entire idea that speed and distance have meaning on indoor rides. It took awhile to get comfortable looking at hours instead of miles.