TrainerRoad not reading Kickr speed

Hey guys

I’m having some issues with TrainerRoad not reading the simulated speed from my Kickr. For those that doesn’t know, the Kickr can simulate speed based off of power while in ERG mode. Which makes it possible to ride in a very low gear (a lot less noise) and still get a somewhat realistic speed reading. I know speed and distance is very much irrelevant, but that’s what everyone else measures and I also have a stupid distance goal for 2019 that I’d like to be able to hit.

Anyways, on Tuesday I did a ride where it worked like a charm, which was also the day I did some testing to see how much different the Kickr and my PM measures, so I started the ride only pairing TrainerRoad with the Kickr and only later added the pedals (5 % on a VO2max session was too much). But it still read the simulated speed right for the whole ride. You can see it here (TR) or here (Strava - has speed). On Saturday I did an other session where it never seemed to work, which you can see here (TR) or here (Strava - has speed).

After the Tuesday ride I’ve updated the firmware on the Kickr and TrainerRoad has had an update. Now it won’t read the simulated speed on TrainerRoad, but if I pair my Garmin it’ll read just fine.
I’m suspecting that running powermatch on TrainerRoad might influence it, but I’m not sure. When I use the Garmin I only paired it with the Kickr and then it reads fine.

Anyone that’s had the same issue and know of a fix?
I would like to keep using powermatch since the Kickr reads kinda far from my PM, and it’s not even consistent how much the offset is.

Edit: Added Strava links.

I have tried to use the Kickr Simulated speed for TR but it has never worked. It always gives me speed at around 22km/h since thats the gear/cadence that I have been using.
The speed goes up and down depending on the cadence but never by wattage.

If it has worked with you maybe I will look into it more and see if I can get it working. For me I have not been able to get it working on Garmin either.

1 Like

I’ve added links to Strava, I forgot TR doesn’t show speed/distance. As you can see it worked fine on the Tuesday ride, and on the Garmin it worked fine yesterday as well, you can see that here. I really hope someone has a fix, it’d just be nice to have “correct” speed/distance.

Oh yes. I was also speaking bit off. What I meant was that I have not been able to get TR to record simulated speed so it would go from TR->Strava. Or to get it working with Garmin at all.
I’ll give it a a go tomorrow and see if my ride tomorrow will get the simulated speed.

I guess I do not know what you mean by ‘simulated’ speed. I say this because
the Kickr has a sensor which records the rpm of the cassette, which, in turn, is
the same as your 700c tire rpm. When it saves the ride, it always shows the speed
on my workouts.

At least the kickr core has a option for simulated speed.
If using ERG mode you can go 38km/h with big gear with lets say 90W or you can go 22km/h for example with 250W depenging on what is the cadence of the rider or the flywheel RPM.
If you select simulated speed the kickr won’t send the RPM data of the flywheel but an estimate what the speed would be in real life with current wattage. This way you can run one small gear thru whole workout and still get speed changes in data. Even that the flywheel RPM stays the same.

This from Wahoo website:

EGR Mode Speed Simulation: This setting simulates speed based on power input for greater accuracy of speed data. Enabling is a personal preference, will not impact overall trainer functionality, and not required (most who train with power are not concerned about speed data).

1 Like

Jup. That’s exactly what I’d like. But apparently it still sends the original speed data since TrainerRoad won’t accept the simulated values… well sometimes it won’t, and sometimes i will.

I don’t have a session tonight so I’ll try a few things to test it out. But would be nice if someone else has found a solution.

Ah, I see said the blind man. I thought one would use Standard
mode. I understood standard mode

  presents a realistic resistance for the speed you were doing. 

Since I have only been doing erg mode

I have not tried that yet :wink:


Fairly certain it is a Wahoo issue, not a TR issue.

I’ve spend a lot of time trying to get this to work reliably. In another thread the procedure is documented based on iOS and Kickr 2017 direct-drive (wheel-off). The basic procedure is:

  • launch Wahoo Fitness app, verify ERG Mode Speed Simulation is set, and start a workout
  • force quit Wahoo Fitness ap
  • launch TR app, load workout, and start
  • do not use TR app to do spindown

I’ve spoken with Wahoo support, there are two problems with ERG Mode Speed Simulation:

  • officially support with Wahoo apps
  • no support for 3rd party apps

And I’ve observed that will ERG Mode Speed Simulation will reset to OFF if you do a spindown in TR app. And if you stop doing spindown in TR app, ERG Mode Speed Simulation will often randomly reset to OFF.

For those reasons, the procedure I’ve described has generally proven reliable and a TR recorded workout will appear in Strava with reasonable speed estimates.


I’ll try this tonight, I’m running it on my windows laptop but it might still work. Even though I think I’ve done that exact thing multiple times and it didn’t work.

But what bothers me about TR is that it always works with my Garmin, it’s just TR that refuse to read it (again).

I checked my simulated speed setting yesterday evening since I knew I will be on a tight schedule today morning. The Simulated speed was off and after closing the Wahoo app and powered off the kickr to see if the settings are saved. They were.

Today morning I started my workout without remembering to check for the simulated speed setting. Midworkout I remembered this and noticed that the speed is not changing according to watts.

I did not wan’t to stop workout to check the setting since this can sometimes take a while. So after workout I did open the Wahoo app to see that the simulated speed setting was set off over night.

Maybe the simulated speed will work, maybe not. But at least you have to remember to check the settings in wahoo app before every ride.

Hi again,

Today I remembered to check the settings in wahoo app. I enabled the simulated speed setting since it was off again.
After that I closed all the app and strated TR and my Garmin F5+.
F5+ was showing speed my watts. And after saving TR ride and automatic sync to Strava the speed was by watts in there as well.

So can’t help with why your simulated speed is not working but for me at least I have to but it on for every ride.

I’m running kickr core and ant+ cadence/speed and HR. BT and ant+ for core.
With OnePlus 3T and Android 8.0.0 for TR.

I previously had problems with ant+ and bt with core and ant+ sensors but they were solved by tweaking the battery optimization settings in Android.

That is good to know. But I’ve tested both yesterday and on Wednesday, and I still can’t make it work.

On Wednesday I did as @bbarrera said above, but on my windows PC, and it still didn’t work. It only read the speed right on the Garmin (Edge 1030), but when I saved the file from TR it had the flywheel based speed.

I’ve also noticed that when the Kickr gets powered off it loses the speed setting (but strangely remembers that I don’t want ERG-watts smoothed).

A quick question: Did you save both to Strava without deleting one of them?
So Strava could have merged them. When I think about it, the only time it worked I didn’t delete anything on Strava and it still only showed one workout, but every other time I’ve tried I’ve saved the Garmin file first, deleted it and uploaded the TR file.

Yes. I have the TR ride as well as Garmin ride syncing to Strava. Once I have had a problem with double ride on strava. That was when I forgot to stop or start Garmin at the same time and the data seemed different for Strava.

But for the other rides I don’t get duplicates so it could be that Strava is doing some kind of merging with the data from bouth.

Damn it, here I thought I’d given up and couldn’t be bothered anymore - guess I’ll try again. You also read from a PM or only from the Kickr?

I only read from the Kickr Core power. Just got the new Assioma Duo pedals so let’s hope that wont cause any more problems.

I think that is one of my problems, that I want to read from my pedals. There’s quite some difference between the two so I’m testing and using the pedals with powermatch so I can use the same data outside. I’ll just give it a go again. But I can’t be arsed to have both my Garmin and TR running every time, so I might just setting on a higher gear and live with the noise, or just say screw it to the distance readings.

I have been running Garmin to get the training status etc correct to Garmin connect. But otherwise I would like to use just TR for the indoor sessions.

TR can do that. TR syncs to Strava, TP, and Garmin.

Yes, it sure syncs but it won’t update the Aerobic and Anaerobic training effect etc that is calculated by F5.
At least it didn’t when I started with TR. Maybe I’ll test if that has changed.