Elite Tuo calibration issue


When attempting to calibrate my elite tuo with the trainerroad android app I get a calibration failed on every attempt. The app prompts me to pedal to a speed of 4.2km/h. After reaching this I stop pedalling, as prompted. And soon after the speed returns to zero I get the calibration failed message. I have tried this both before and after workouts so there should be no issue with the trainer not being warmed up. I am able to calibrate through the elite e-training app, which requires a speed above 33 km/h for spin down. I’m not sure if this calibration is compatible with the trainerroad workouts though.

Any help on this issue is appreciated.


Best to email support@trainerroad.com for help with issues like this.

You have to pedal MUCH faster than this…

I read somewhere that you will need to get to around over 32kmh to get to calibrate.

That’s the only way I have been able to successfully calibrate it…
or at least that what TR tells me…

I have both the Elite Suito (Philippines) and the Direto XR (US), and I’ve had issues calibrating both with the android app. The cal app just would not allow me to attain calibration.
I downloaded the MyEtraining app to my windows 10 laptop and used BT with the direto, calibrated that way. But its still is a little finicky about hitting 20mph. Seems like you need to be in the right gear and spin up smoothly. Since I use the laptop for workouts, and not the phone, this works much better for me. Although with garmin V3 power pedals and power match, I’m not sure trainer calibration is critical. Also, make sure all other unnecessary BT/Ant+ connections are off. In other words, only the trainer and the app should be in communication.

I had the same issue. One day I got frustrated and peddled as fast as I could, beyond the recommended speed, and it worked. Try peddling fast and it should work…good luck.

1 Like