Trouble with Erg Mode

Hey guys,

I have an Elite directo and last night tried to do the ramp test but had some trouble. Basically, the erg mode “kind of” works but also kind of doesn’t. It takes a long time to react to ramps / steps and sometimes just doesn’t react, period, and i have to shift up in order to keep pace. Otherwise i’m riding at 176, the prescription steps up to 186, I keep pedaling (expecting resistance to change automatically because, you know, “erg mode”) and it just doesn’t change. I ride an MTB (so limited gears) so this is not ideal.

I am connected via Bluetooth to an iPhone which i use to direct the session. Is it better to connect via Ant+ instead? If so I could get a dongle.

1 Like

ERG mode should work via both Bluetooth and ANT+, so that should not be causing the issues you describe.

If you go ahead and reach out to our Support Team at support@trainerroad.com, they would be happy to take a look at your logs and help you get your trainer up and running as it should. They are the experts on this sort of thing :slight_smile:

1 Like

I have the very same problem with my Elite Direto. It can take 5-10 seconds to stabilize. For 30s or longer intervals this is not really a big deal. For anything shorter it becomes problematic. I’ve found that lowering my cadence to sub-60 for about 5-10 seconds before the higher intervals allows the machine time to crank up its internal resistance, and it will “adjust” to the new power target much quicker. This is a hackish workaround, NOT a real solution… I wish I had something better :slight_smile: Hopefully this trick works for you as well.

1 Like

In my experience with Elite trainers, your best bet is find the box and take it back ASAP! I bought a ‘bargain’ Drivo, only to have the same problem you mentioned. If you go on their forum, there are threads from 2017 where they say there will be a firmware update ‘soon’, so you can imagine when that will be… and anyone that complains, the company replies that they must be pedaling wrong! Yes, really…

lol

okay fair. maybe that’s the answer. I’m using powermatch with my PM (Power2Max) controlling power and the Direto controlling the resistance, and maybe it just can’t handle it.

thanmks everyone

What gear are you in for the ramp test? I’ve experienced issues in the past with my Elite trainer when attempting ramp tests. I was trying to use a fairly big gear, so big ring and a few cogs from the 11 and has the same problem you mentioned. I usually do my workouts in the small ring and somewhere in the middle of the cassette and have no issues. I’ve then used the same gearing for the ramp test and, boom, no issues. Not sure if the gearing has something to do with it, but I’ve been able to repeat these results I’ve mentioned. Just throwing in another $0.02 to the discussion, but like @Bryce said, i’d reach out to TR Support as I’m sure they’d be able to help!

1 Like

Interesting. I’ve reached out to support but in the meantime, i’ll try dropping the gear and see if that makes a difference.

Thanks!

I have the same trainer and always use the small chain ring. Never had an issue though I’m not worried about it taking 5 seconds to catch up - if it does. :thinking:

All, I can now report (sheepishly) that I downshifted a bunch and it worked fine.

On the elite forums, just what I read no first hand experience, there was mention that elite can make it respond faster. Unfortunately, they have to login to your computer and run something to update the trainer…from what I read.