Did AIFTP break the app?

Today was my ramp test day.

So I let AIFTP calculate for me.

All good so far.

I then went to do an indoor ride, instead of the suggested outdoor ride.

Only to find I’m unable to open the suggested workout, in anyway.
Restarting the app etc, hasn’t worked. :man_shrugging:t3::man_shrugging:t3:

Tried to upload a screen recording, but it’s not allowed.

My app seems to work, however I am getting timeouts on the Traineroad website, maybe it’s related?

What happens if you delete the workout and re add it manually through the web browser calendar?

Sorry about that, brief outage that we fixed!

Are you still having trouble? I wonder if it was related to that outage, but please reach out to support@trainerroad.com so you can send that screen record in if you’re still experiencing issues.


Cheers Ivy

I loaded the workout manually, but the original outside version is still broken :man_shrugging:t3:

It’s not really a problem, it just seems like a bug.

I think I know whats up.
You had a pending adaptation for that workout:

Try opening your career page + calendar on the web to check that out and see if you can open it there after accepting or denying adaptations.


That’s got it :ok_hand:

That’s fixed it.
It now shows up in the app too.

That’s a strange little bug.

I’ll remember to check the web version next time :+1:

1 Like

I dont believe its a bug (or a result of your AI FTP Detection result), as I dont see any other reports of this so it may be a result of that temporary outage, but I’ll keep an eye on it. Sorry for the trouble, thanks for checking in about it!

1 Like