Computer has blocked TR

Before the holidays my son smashed my laptop and so I got them to put trainer road on my work laptop and it worked fine however it updated yesterday it updated and now I am left with this, I think the answer will be you can’t do anything but is there anyway to bypass our network manager (who is on holiday for two weeks) and get TR working?

Probably not unless you can contact someone else who can log into the Admin.

Perhaps you might be able to borrow a friend’s iPad?

Unfortunately unless you have an admin login or unless someone in your workplace does (besides the network admin) that could give permission for the app, you’re probably not going to be able to use it

1 Like

If you right-click on the TR shortcut, do you have “Run as Administrator” in the menu? Works for some things, not for others though.

A couple possible options:

  1. Use your phone (which is what I do)
  2. Use a tablet or iPad
  3. Ride the “outdoor” versions of the workouts
  4. If the workouts are simple enough, print out the descriptions and make yourself a cue sheet (this is basically the outdoor versions suggestion with more steps).
  5. If you have Zwift you can “build” the workouts in there.

This is a small setback, don’t let it derail your training!


Unfortunately there is nothing we can do to bypass system administrator settings, however, we have a couple of versions of the app you could try to install. There is a chance that one of them will be able to run successfully.

Air App (need Adobe Air installed first)

Legacy App:

Beta App:

If you are unable to get these versions of the app running, then using your mobile phone with TrainerRoad will be your best option until you can bypass the administrator settings.

Good luck, and let me know if you’re able to get up and running :+1:.


Unforunately none of that worked, just sorted it on to my iphone so that is something. Santa is bringing my wife a new laptop on Wednesday so maybe she will let me load TR on it