Bluetooth pairing woes with ios and 4iiii power

Hi, first post here.

I’m coming back to Trainerroad after a break of a couple of years. Obviously things have moved on and this has left me in a bit of a hole.

I’ve an iPad2 (yes 2 as in second generation) with an ANT+ dongle and an iPhone 6. The iPad is running v7 of iOS which is the last version that’s usable on that device, the phone is running the latest version.

I’ve got a 4iiii power meter, gen 2.0.

The power meter is seen by TR on the ipad and power is displayed. On the iphone, Precision’s SW picks up the device over BlueTooth and I’ve updated the firmware via their app so I know the phone and meter can communicate. But the TR software (latest version) does not find the meter. The screen shows BT as “on” but five minutes of pedalling and no joy.

I’ve turned off the nearby Wifi router and replaced the battery but still no joy.

This puts me in an awkward spot as the app on the iPad is old and doesn’t pick up workouts like the Ramp Test (presumably it uses newer iOS features) but annoyingly has dropped the 8-minute and 20-minute FTP tests from the various plans! The phone shows the test but I can’t do it since there’s no power data coming through.

Any ideas?

Your 4iiii won’t be able to maintain more than one active Bluetooth connection at a time - this is almost always the root cause of problems like this.

I’d go ahead and ensure that the 4iiii isn’t paired to anything else at all - another device (e.g. the iPad), another application (e.g. the 4iiii app), or even your iPhone 6’s internal Bluetooth settings. Once you’re 100% certain that the 4iiii is paired nowhere at all via Bluetooth, go ahead and check if the TrainerRoad app on your iPhone 6 is able to see it. :slight_smile:

If you’re still running into problems, go ahead and reach out to and they’ll be happy to help you out.

1 Like

Ta for that.

Properly closed the 4iiii app and ensured that the crank wasn’t in the list of devices and it appeared in the TR app for a second or two then it was back to searching for devices. Checking both the 4iiii app and devices showed it hadn’t appeared in those.

So it can communicate but it looks like there’s something else trying to connect with it. More investigation!

My wife has an ipad mini currently running iOS 12.x so she’ll update that and with a 30 pin to lightning converter (if I can find one these days) I should be able to get things going :grin:

Looks like my wife’s iPad Mini picks everything up over Bluetooth so I’ll run/ride with that for now. Still not sure what’s still connecting to the 4iiii on my iPhone that’s stopping TR doing so.