Bkool Smart Pro trainer not recognized by Trainerroad SW but by others OK

Hello

I cannot connect my BKool Smart Pro 1 (ID: b0-5b-db-26-75-48-3a) as a smart trainer anymore with Trainerroad. The software recognizes it only as a power meter, only in Bluetooth connexion. In ANT+ connexion, it does not recognize this trainer, just my heart rate monitor and other standard power meter.

I checked my trainer firmware and it is the latest (FW: 3.16).

Furthermore I checked the following:

  • With Bkool Indoor software, I can ride with this BKool Smart Pro trainer in ERG or non ERG mode. Bkool Indoor Cycling software recognize the trainer as smart trainer in ANT+ and Bluetooth.

  • With Trainerroad, I installed the trainer from my colleague, a Bkool Smaart GO and all worked fine for Trainerroad software.

  • It is like my smart trainer got black listed from the trainerrroad software (as it does not work on my PC but also my Android tablet/cellphone)

Can you please help me or orientate me?

Thank you in advance

Simon

It’s best to contact support@trainerroad.com for technical issues like this (if you haven’t already done so).

Already in process
No feedback yet
thank you

2 Likes

I have the same problem with my bkool pro, you could fix the problem

I had this issue a while back with the exact same symptoms. I could still use Zwift and Bkool but not TR. Turned out to be the firmware was out of date on my trainer (Bkool Smart Pro 2)

Download the “Bkool Toolkit” app on your phone and update the trainer firmware if you haven’t already. This should resolve it.

2 Likes

Hi,

I already uninstalled the garmin program and it did not work
either. It is proven that it is a problem with the roller.

I was investigating on your page and it says that from the
bkool application I can change to ANT + FE-C, the problem that the version
shown in the attached photos is a previous version to which it is allowed to
download now. Maybe you have the driver to install de bkool old version.

image.png

image.png

image.png

image.png

It can still be done in the new version.

If you don’t see the option to switch to ANT+FE-C in the device menu it means your trainer already has it enabled.

I’d check the following before trying to connect to TR. If this doesn’t help then I’m unsure what else you can try.

  • Bkool Smart Firmware update
  • ANT+ dongle working / close enough to trainer
  • All other training software is closed / not connected to the trainer via ANT+ (Bkool, zwift etc.)

Also, check this…

Hope this helps.

Hello

Thank you very much for your interest and for the good
service presented. I was researching on some blogs and platforms and I made all
the recommendations that you gave me. I finally determined that the only way to
update the bkool pro firmware was from the previous version of the bkool
simulator. For this, I looked on youtube and found a driver to download the
version of the bkool simulator that I had installed on my machine, I installed
it and it allowed me to change the firmware so that ANT + fe-c is enabled.

Now I can connect in ERG mode to your TR simulator using the
ANT + antenna.

If you have the same problem with other Bkool Pro 1 users, I could send them the link (it is in Spanish) or the driver so they can solve
it.

Again thank you very much for your support