Beginning of workout hard

I started TR last night and it took forever for my Kinetic smart trainer to settle in. I was mashing out close to 300W and it just kept climbing. I tried to peddle faster and the power would climb instead.

Anyone have this happen to them before?

image

This stuff does glitch the odd time. I find that if I stop completely for a few seconds it resets and you can go back to normal. The worst is when you’ve been hanging on for dear life during a VO2 max interval and the resistance fails to drop at the end of the interval. Enough to break you :rofl:.

On the other hand. If you’re not used to erg mode it needs a particular approach. You need to keep your cadence steady. The trainer will adapt resistance to your cadence, keeping your power steady.

1 Like

define forever? On my Kickr and H3, it took probably about 30 seconds or so for warmups to come in line. It happened with TR, and it happened with Zwift. If it’s that hard, I would change gears, though 300W is about right. I’m also, mostly, a big ring user, so it’s a bit more power to start off with. I believe it was less with the small ring.

LOL. I’ve had the exact same experience. The worst I’ve had was during 15/15 intervals, and it connected both together, to make it a 45s interval, or it comes down for 1s and then back up, lol. I’m so glad I’m doing base now, lol.

2 Likes

Forever as in it took about 10min to settle out. 300W is basically double my FTP, so for me it is a lot.

Ill try coming to a complete stop to let it reset then starting again to see if that works.

Been using TR for over a year so I hope this is just a fluke.

Any recent changes to your setup?

  • (Trainer, firmware, controlling device, etc.)

Do you calibrate it in app or with another app? I’ve had workouts go haywire because after I calibrated in rouvy, went back to TR, rouvy was still operating in the background and the two apps were sending contradictory signals.

1 Like

If you reach out to our Support Team at support@trainerroad.com, an agent would be happy to look at the log files for this workout and help you piece together exactly what went wrong :+1:.

1 Like

I had this tonight.

I have been using my iPad TrainerRoad app to control my Kinetic Smart Control (1st Gen). Tonight I used my MacBook, as I’m looking at switching to Xert and want to gather HR data with my indoor training, and at the moment I only have an ANT+ HR strap (Garmin Tri-HR) so wasn’t recording this via the iPad app.

At the end of my last workout (Sunday) I updated the trainer firmware via the Kinetic Fit iOS app.

I updated the TrainerRoad OSX app, as I hadn’t updated since end of last year. When I tried to start the workout, the Kinetic Smart Control trainer would get up to between 250-300 Watts as I was trying to get the Erg mode to kick in.

I tried using the TrainerRoad iOS app to calibrate the Kinetic, but this didn’t work. I used Kinetic Fit app and this said a firmware update was available, so I updated and reconnected the unit to the Kinetic Fit app. I then successfully completed a calibration.

Going back to the OSX TrainerRoad app I tried over and over again to get the Smart Control unit to work. Just never did. Spent two hours trying to get everything to work. I’m absolutely livid as I don’t have a lot of time to train with two kids under three, and wasting two hours is just not viable for me - I could have gone for a run, but instead I get no workout, and a boatload of stress.

I’ve sent Kinetic’s support an email. Will see what they suggest, but that’ll be a few days before I get a response.

If you work out what was going on, would you mind posting here? Similarly, if I get anything useful back from Kinetic, I’ll post it up here.

When this happens stop peddling. Let power go to 0. Pedal again and get to your target RPM and hold that RPM don’t raise or lower it, hold it steady and let the trainer settle in. That usually works for me with this issue.

1 Like

I use TR on my desktop and I did a update. I didn’t think to calibrate it again after the update. I would bet that is it.

Hope you have more success than me. Can’t calibrate via the macOS app. TR will calibrate the KK Smart Control via the iOS app, but then as soon as I try to use the macOS app, the same issue returns and I’m struggling to reach a workable cadence whilst pushing 300 watts, despite the initial warmup only commanding about 130W.

Giving up on the app. My annual subscription is up at the end of the month and I’ve been toying with Xert or Sufferfest. Need to think whether this is the push I need to switch.

Are you sure this problem is TR specific?

I’ve just seen so many issues with KK trainers, I tend to question then before the app.

Could be good to hit a trial period of the other apps to validate what is or is boy happening.

RGT Cycling is free premium right now, and might be worth a test too.

Zwift no problem. Will try Sufferfest and Xert this week. TR iOS app worked after a few goes at calibrating. Kinetic Fit app works. TR macOS seems not to like the Kinetic.

I don’t think Kinetic is a fantastic unit. I had a fluid RocknRoll, so it was the cheapest option as I liked the movement of the RnR. In an ideal world I would have gone Tacx/Wahoo as they seem to be the best units at the moment (Kickr’s issues aside)

1 Like
  • Does that include Z workouts, or just sim mode?

TBH, I think you should contact support. Complaining on a forum is good, but it doesn’t always lead to action as not everyone reads every post of every thread.

Tagging @Bryce and quoting, but do follow up with support.

I ended up hurting my back and took 10 days off, but wanted to follow up with everyone that gave feedback. I reached out to TR on the long time it was taking to sync. One thing he mentioned that I didn’t think of was that I moved from using my phone to run TR to my desktop. I then calibrated the trainer along with my power pedals through the TR desktop application instead of their individual apps. Still takes a few seconds to sync up when starting, but not nearly the 1 - 2 minutes it was taking before.