Apple Watch workout imported but without power data

I used my recently updated Apple Watch to record a mountain bike ride this morning after connecting the watch to my 4iiiis power meter. Everything worked ok but when importing the ride from Apple health, both TrainerRoad and strava have failed to import the power data. I can see the power data in the Apple fitness app and in the Apple health app but it doesn’t show up in the imported ride in strava or in TrainerRoad. I also tried using RunGap but it doesn’t seem to be able to pull the cycling power data either. Any ideas/fixes that anyone has found?

1 Like

I can’t help you on why the TR side failed, but if you need an immediate workaround, HealthFit (small 3rd party app), is already compatible with the power data in Apple Health, and works for getting that out to Strava/etc…


Thanks Ray. I was just reading the same thing in one of your articles. I guess I will give it a try. Getting data to synchronize between all the different platforms and devices is a never-ending headache

It might be that RunGap doesn’t support syncing those power fields yet (or you need to install an updated version of it). In any case HealthFit does and is awesome. I set it up once and it automatically syncs in the background without giving me duplicates.