ANT+ driver issues 2022 Windows

Couldn’t update drivers on my usb ANT having tried all the usual stuff on google . Found this and it worked first time-

  1. Open Windows Update, hit check for updates, then ‘View optional updates’. In Windows 11 this is found in the Advanced options menu.
  2. Expand the list of driver updates, locate the ANT+ driver (it shows up as Dynastream Innovations), select it and press ‘Download and install’ to complete the process.
1 Like

Hi, thanks for sharing, but I couldn’t find the driver update on the list. Is there actually a link to download this manually?

I’m looking for help on this subject as well. I tried manually located and installing drivers from “Device Manager” and that didn’t even seem to help.

In Windows Updates you have to force it to search for new updates several times per my experience with this last week. The drivers show up under the “Advanced Options” tab when downloaded too. PITA!

Screenshot 2022-01-16 153917

Thanks @Hertzlocker. For some reason my Windows 10 Windows Updates page was not giving me a list of of drivers as each of you described. Maybe because certain settings are “managed by my organization” aka IT.

I did however persist and find a solution that may help some. I was getting the .NET framework error when trying to install the TR ANT+ drivers. It would say that I needed .NET Framework version 3.5 or higher, and that caused some confusion for me because after downloading most recent .NET framework from MS website I got an error saying I already had the most recent version of .NET installed.

I found how to check and enable .NET framework for Windows 10!

Go to Control Panel>Programs and under “Programs and Features” there is an option to “Turn Windows Features On or Off”------BINGO!

Click that and follow the directions to enable both .NET Framework 3.5 and .Net Framework 4.8.

NOTE: My .Net Framework 3.5 was not enabled originally AND only a couple of services of my .Net Framework 4.8 were enabled. IT DID NOT work for me to only enable everything in .NET Framework 4.8. I had to enable everything in .Net framework 3.5 as well.

Go locate the drivers and install them. For me they were located here:
C:\Program Files (x86)\TrainerRoad USBDrivers\dpinst.exe

I hope this helps someone else with a IT managed laptop.

1 Like