Android App stopped working

I last used TR on my Samsung Tab S3 at about the time the latest Android update came out (14th Jan) and all was well. Tried it yesterday and ERG mode wouldn’t work but would still connect to my trainer presumably because it had installed the update in the meantime. Downloaded TR to my Samsung A5 phone and everything works so thought to uninstall and reinstall TR onto the tablet. Now it won’t even launch. I only tried TR because Zwift was so poor on Android and am a bit ticked off that to get it to work on a tablet means I have to buy a new one, or a laptop or and iPad. Shame is that I really like TR.
Anyone else have the same issue or know of a work around. I know I can mirror my phone on the tablet but that’s a bit of a faff and it was working fine two weeks ago.

Did you upgrade to android 10?

I’ve had a possibly related issue, though I assumed my trainer was at fault. I use the Android app, and while it can connect to the trainer and read the power output, Erg mode hasn’t worked initially for the past four workouts (so since Saturday). I have an Elite Qubo Digital Smart B+ (relatively crappy wheel-on smart trainer), and I have needed to complete the setup wizard in the MyElite app (which I don’t normally use) to get Erg mode to turn on. The setup wizard doesn’t do any calibration (my trainer can’t be calibrated without an external power meter); it just sets up Bluetooth connections.

Android version 9, TR app version 2020.3.0.92026

No still on android 9 and it says it’s up to date

I have the Elite Novo Smart which is very similar to yours i.e. relatively crappy. I’ll try switching ERG mode on through the MyElite app although TrainerRoad said it was in that mode already.
Thanks

Oh hilarious, maybe it’s an Elite thing. Super.

Just to clarify: I didn’t explicitly switch it on. I went through the trainer configuration wizard where it connects to all the sensors (no opportunity to configure trainer settings there), and then I used one of the POWER mode “trainings” in the app to confirm it was working again. At no point did I actually change any settings anywhere.

I’m so sorry to hear that you’ve been struggling with such frustrating issues on your Android tablet. I’d recommend reaching out to our Support Team at support@trainerroad.com since they are the experts on this sort of thing. They would be happy to take a look at your setup and help get things straightened out for you.

Sorry again, we look forward to making things right :+1:.

1 Like

Sure it should work on the tablets and support might fix that for you… but if it works on the phone, just use that instead. No need to buy new tablets, laptops or whatever. The TR interface works very nice on a phone screen. Just mount your phone on you bars and go!

Well after a bit of messing about, I’ve got it to work. What seems to be important is to turn off bluetooth and pair with the trainer using ANT+. Bluetooth can then be switched on if necessary to pair with other devices such as cadence or heart rate. This way, ERG mode works. Also the app seems to have come back to life on my tablet after uninstalling, reinstalling again.
So all good. Thanks for comments. Anyone else with the same problem (ellotheth) could try it out too and see if it works.

If after uninstalling and reinstalling TR is not working, then may be this is a browser problem. You may change the browser using content://com.android.browser.home/ syntax.

I’ve had several mid-workout freezes of the app on my Samsung Galaxy 7. Currently running Android 8.0. Rebooting the phone works. It’s annoying, I just have to remind myself that training is a process, not an event.

Just had the android app freeze this morning mid-threshold set. I think I had some Ant+ signal dropouts because all of my devices dropped connection (either something on the App side or the Garmin Ant+ stick I use or maybe the battery is getting low in HRM). Battery is new on my power meter as I just changed that just over a couple of weeks ago because I was having ERG mode dropouts (usually due to PM dropouts with low battery).

Had to close the app since it froze and restart to get the devices to connect again. Also running Android 8.0 on a Morotora Z Play. Ant+ stick is a Garmin 2.0 version (the version that looks like a USB thumb drive longer sized ones). I know I’m due for a new phone but waiting for stuff like the Pixel 4a or the OnePlus Z (or whatever they will call it) to come out to drive prices down. No way I’m paying for a phone that nearly is $1000…that’s just highway robbery. What happened to flagship phones being $500 or less?

Also, this is more of rant and hope they fix it but if the app crashes or freezes I’d prefer it to not auto-upload/sync the ride with Strava or Garmin Connect. When I resume the workout I’ll end up with 2 workouts uploaded with the first being at the time it froze and the 2nd the full workout. Strava just takes the first uncompleted workout and won’t accept the fully completed one. I have to download the fit file and manually upload to Strava to fix it (and delete the prematurely uploaded one first).

I guess it’s a feature request for the Android app - don’t automatically upload workouts until it is either fully completed or you select the “save and close” option. If it freezes unexpectedly or if you close it by accident (I’ve done this trying to mess with split screens to watch media) I don’t want an incomplete workout uploading.