Zwift erg mode not working

So whenever I am doing a custom workout on ZWift in erg mode and whenever I spin 90+ rpm, I start spinning out crazy like there’s no resistance. Now, I like to keep my cadence between 85 and 93. So please tell me why it is happening. I have Wahoo Kickr v6, and I was using the settings called erg power smoothing. In that, I was not facing any issues because the erg power smooth settings keep me extracting on the target watts and show you a clean and straight graph, but I have recently toggled off the setting erg power smoothing because it shows you a fake graph, and in actuality, the power graph naturally goes up and down. But my normal erg mode is on, and I am facing an issue in that whenever I go above 90 rpm, my residence just goes to zero, and I spin out. Can you please tell me the fix.

And I am also sharing the pairing screen of ZWIFT, so please tell me what is the best way to pair your kicker. Incase thats the issue. There are two options, which one should I select?

Anyone knows? Please help me with so suggestions

Have you tried Zwift support or their forums?

4 Likes

Is but not replied yet it has been few days that’s why i am asking here

It looks to me like your choices are between a physical connection and wireless. Do you have a physical connection between the trainer and the computer? If so, I would use that one.

If you’re using wireless (or have ever used it before), this kind of problem usually comes when two devices are both trying to connect and control the trainer simultaneously. They will end up swapping control back and forth and create issues. This can happen even if you’ve closed the controlling programs.

Have you ever controlled the trainer with a device other than one you are trying to use now? If so, my suggestion is to turn off every single wireless device you own and then turn on only the one you want to control the trainer. If that fixes the problem, then you can slowly turn on every other device one at a time until you figure out which one is interfering.

So i have wahoo kickr v6 and it’s wireless it has inbuilt wifi feature and i don’t know what is the ant+ signal showing on the pairing screen maybe its the wifi but i don’t know maybe i should try Bluetooth? And secondly i don’t have any app running in background or any thing connected on background and one more thing have you read the erg power smoothing sentence which i have said in mu first message. So what do you thing? Pls reply back and suggest me

Try what I suggested above first

The top symbol is the one used for either Wifi or DirectConnect cable connection. It wouldn’t hurt to try the Bluetooth connection. I don’t expect it to solve the issue, but it’s worth a test to know for sure.

does it still work OK if you put the power smoothing on?

So i have said that i have tired that but the problem haven’t solved

You have tried turning off every device and turning on only the one running Zwift? Not having apps running is not the same as turning every device off and leaving it off.

Also, make sure you unplug the trainer and then turn it back on too.

Yeah so as i have said its work when i toggle on the erg power smoothing but the only problem is that the power number will be extract what you have set it to
For example if you have set 250 watts so then the trainer will keep you at 250 no matter what if you slow you cadence or increase and it gives you a clean graph on a straight line. But that’s the issue because if you apply to much force then also you will see your power will be at 250 watts thats what power smoothing will do and actually it has to much resistance you will get fatigue fast. And its fake your power graph to make it look clean. That’s why i bave toggle off erg power smoothing but my normal erg mode is on and that’s where i am facing an issue

Yes and actually i switched off everything and just opened zwift but then also no resolution. I will try pairing with Bluetooth but as someone said it will make no difference

Do a Trainerroad workout instead - it’ll fix it.

1 Like