Workout text behind Netflix?

Doing an easy session watching Netflix and just realised the workout text is behind the Netflix window? I’ve got TR in minimal mode.

Previously the text always appeared over the top of Netflix?

Any ideas??


I never get how people watch Netflix. I Am doing mv base 2 and there is too much pain and focus required to watch on the side. Hope you get it fixed!


lol… same here. always when i try to put NETFLIX during workouts… after the w.o i’m just… 'wtf did i just watch?

1 Like

It’s an easy week before a ramp test

It looks like you have Netflix in full screen mode. Have you tried just maximizing the browser instead?

I know with certain application (like Zwift) having it set to full screen instead of windowed can interfere with everything else.

I watch dumb alien or conspiracy documentaries. Lame movies. Fluff really. Something I can lose focus on and not miss any real information.

There’s some weirdness going on at the moment! There’s also this thread about nothing being visible on top of full screen video.

1 Like

I tested it and made the screen look like the OP. It worked fine. (Excuse the lack of image. Netflix doesn’t get captured with PrtScr).
I wasn’t running Zwift.

Have you turned off Workout Text? If you go into settings you can toggle it on and off.

No workout text was on, I could see the last few letters to the right of my Netflix screen!

1 Like

I used to have this issue, and for years what has worked for me was to first open my browser then go into Netflix, then open TR. Opening TR first seemed to cause the text hiding.

FWIW, I watch Netflix during every ride, even the really tough ones. Never had a problem focusing on things, but I do definitely keep what I watch on the non-cerebral side.

As Danimal123 said, you can also try clicking on the TR app to give it focus. If that doesn’t work you can move the TR app a bit on top of the browser.

What is happening is that the windowing system thinks Netflix is on top, in terms of z-order, and is giving the browser the option to use hardware accelerated overlays. It can also do this if the browser is unobscured. Just speaking in hypotheticals here.

When the browser is not the topmost app, the decoding should be to an off-screen surface and then the windowing system will composite the display.

Another option, not sure which OS and browser, is to disable hardware accelerated overlays in your playback options. I don’t know if that would be a Netflix setting or a browser setting.

Of course, just today my workout text started showing up behind my Netflix window. Hasn’t done that in years and no tricks seemed to fix it.

I think the last update broke something!!

The same for me, while watching YouTube on a PC.
As said before it seems like the last update broke sthg.

For the sake of my brain, could you please fix it, TRcrew?

Thank you all for bringing this to our attention. If you are experiencing this issue, please report it to our Support Team so that we can properly investigate and resolve this issue. You can reach the team at :+1:.

We have developers looking into the issue as we speak, but the best way to keep you all updated will be through a direct line with our Support Team.

Having the same issue… But with Zwift rather than Netflix. Text is enabled and displays over the desktop but under zwift. Not running full screen mode and the small trainerroad bar is visible at the bottom of the screen.

Windows 10, with no windows updates applied to the device for some time.

Started a couple of days a go. Managed to get it working eventually, but now it just stays behind no matter what.

We’ve just pushed a new Beta that should fix these minimal mode issues! If you don’t want to wait for this to push to our Production version, you can download our Beta apps here.

If you’re already using our Beta program, you should be notified of an update.

Thank you all for bringing this to our attention. As always, if you find there are still issues please let us know! :+1:


Working fine now for me, thanks for your reactivity and your work, TR crew you’re great!!


No such luck. The beta version gives me the minimized bar at the top of the screen and the remainder of the screen is grey. The production release that came out with the release notes for fixing this yields the same original issue.

Both fullscreen and windowed windows overlay the trainerroad text. In the beta version the issue is even worse.

Screenshot is clean install of latest production release - 2020.24.0.40

I like to overlay the workout onto an RGT screen and now I can’t put it at the top of the screen as when I click to minimise the workout it minimises it to the top of the screen but leaves a full blank/black screen below.

It also hides everything else I open behind it - taking a snip o the screen was difficult as I couldn’t see the snip screen

Is it just me? It never used to do this.