Kickr control issues

I have a problem with the TR app sometimes not controlling the Kickr correctly. Frequently I get very high resistance at the very start of a session (see A in the screen shot below), which comes back to where it should be over about a minute. This looks like the TR app takes a while to adapt to the resistance curve of the Kickr.

A second symptom (same cause? separate problem?) is that sometimes I get no change in resistance when the TR session calls for an increase. Sometimes this recovers slowly by itself (see B in the screen shot below) and sometimes I have to fiddle about (pause and restart the session). This looks like the TR app loses the ability to control the Kickr, which could be the app, the Kickr or the radio link.

I’ve tried many things to find the cause of this, including calibrating the Kickr with the Wahoo app and with the TR app, but no luck. Does anyone have any suggestions how to avoid the problem?

My set up is generation 1 Kickr, SRM power meter, TR app on Samsung Galaxy S7, ANT+ (no bluetooth). All software up to latest versions.

1 Like

If you haven’t already, there are several threads related to the KICKR. Use the search function (spy glass) in the upper right corner near your profile pic.

Good luck!

I too have been suffering with this and have had a few service tickets to try and address it. Best example is below where it just wont seem to track properly and makes the entire set unmanageable because of the power demands required.

image

You can see in the first warm-up sprint the overshoot then undershoot of power.
Happens a few more times during the warmup but to less pronounced degree. But then when the actual working sets start it is massive overshoot and then it undershoots the rest of it. As an entire set it ends up calculating on, or close to, target, but the workout is nowhere close with the variability.

I too have done spin down after spin down, pairing and unpairing. It seems to be a problem with powermatch from what I can tell, doesn’t matter if its iOS or Windows application.

As an engineer who has studied and worked with control systems, this looks like a control loop issue to me. The TR developers have a difficult job trying to design an app that provides fast accurate control when the measurement source (power meter) and the actuator (Kickr resistance) are so variable. And the communications channel to both of them (ANT+/BT) is unreliable. But you’d think it should be possible to improve on what we see here.

1 Like

@bredmond @RONDAL - what gear are you riding in? The patterns you describe are similar to what I experienced with my Direto when riding in too big (hard) a gear. Try small chain ring, middle of cassette?

Already doing that. I’m typically in 36-15/16

1 Like

Me too, already doing that.

1 Like

@bredmond FWIW that looks like a minor annoyance as your other 2 intervals are super clean.

Your “B” scenario happens to me occasionally, maybe every 2nd or 3rd workout. Not enough to be concerned, and not enough to impact workouts. My setup is Kickr 2017, iPhone 7 using Bluetooth, PowerMatch with Stages LR, and 53x15 gearing.

I’m also an engineer with some history working with control algorithms. Agree that sometimes it is underdamped with some ringing when jumping low-to-high and high-to-low. However I’ve also found that it usually happens when I’m “sloppy” covering the jump from low-to-high. Finally, Bluetooth can offer a little more reliable communication, as it uses frequency hopping.

PowerMatch can sometimes have some trouble keeping up with resistance changes, but the lower your gearing is, the less pronounced these issues become. I know you are using a fairly easy gear, but if you can use an even larger cog in the back it could help to improve the responsiveness of the ERG commands. Also, having a reasonably high cadence when the resistance changes will also help the ERG adjustment happen quicker and more accurately.

Aside from this, I would recommend reaching out to our Support Team to see if they can learn anything from your log files that can help improve your sensor performance. They can be reached at support@trainerroad.com.

2 Likes

Yes, although the high resistance (almost ftp) immediately at session start is a major annoyance and occurs frequently.

weird, never had that happen.

Thanks. I’ll work my way through those suggestions.

I entered a ticket with support when my Neo would seem to lose control and ramp up despite the prescribed power. They diagnosed that my ANT+ signal seemed to be dropping out intermittently. I noticed this on my own and connecting the two dots it seemed like a good cause. I purchased an inexpensive USB extender cable so my ANT+ dongle was closer to the trainer. Haven’t noticed the issue since. Since you are using a mobile device, it may be harder unless you can put your device on the floor, but then you may need something else to display the screen.

I am curious about the comments made about gearing and ERG mode. How does running an easier gear make ERG mode smoother? From a cadence perspective, I assumed the trainer would just adjust power to cadence, but sounds like gearing has an effect on how much the resistance fluctuates? Can someone elaborate?

I have exactly the same issue except I don’t use the Android app but a MacBook or iPad/iPhone.
I also raised a support ticket and was given the following advice which seems a bit contradictory to what others have said.

  1. Always make sure that your devices have the most up-to-date firmware. Additionally, try to calibrate both the power pedals and your trainer prior to each workout. Both of these tasks should be done through the respective app for the device. This is the only way to check the firmware, and the best way to calibrate. This is because the respective apps have more precise calibration standards for their own devices over TrainerRoad’s.

  2. Check that all of your devices have either a fresh, or full battery. It could be that the pedals show to have enough power to send a signal to TR, but it is not as strong as it should be to function flawlessly. Additionally, check that your Macbook is either fully charged or plugged in, and that battery-saver mode is turned off before starting your workouts.

  3. Try using a bigger gear during those workouts with high-power, short-duration intervals. That, combined with slowing you cadence slightly before starting the interval should help the trainer to keep up with the quick changes in power.

After this I did replace my batteries in my Vector pedals and move my ANT+ stick onto an extension cable to get it nearer Kickr and pedals and saw some improvement but its not perfect. On Saturday I did Baird +2 and during the warmup the first VO2 step up was ignored as was the following valley and only by stopping pedalling totally and pausing workout did I get the resistance to start doing what it should.


It really is annoying, not sure who to blame but it is affecting workouts when I often have to pause, even rewind to restart an interval to point that if I wasn’t on an annual subscription I’d consider moving an alternative to see if it’s software related or hardware.

[quote=“russell.r.sage, post:13, topic:9312”]
I entered a ticket with support when my Neo would seem to lose control and ramp up despite the prescribed power. They diagnosed that my ANT+ signal seemed to be dropping out intermittently. [/quote]

Interesting.

and for the record, this was also seen in Zwift. Momentary loss in power reading and avatar would stop and then it would pick back up again so when they said it, I wasn’t surprise.

I also noticed that in the toolbar at the bottom of TR where you see the sensor status and mode, the dropdown with ERG selected would intermittently clear out. I associated that to the loss of connection and then upon reconnect, the UI wouldn’t re-select the value.

@bredmond according to TR support I’ve had dropouts with ANT+ and that caused a delayed start to a few intervals. Switching to Bluetooth fixed it. As mentioned above, Bluetooth uses frequency hopping and is less prone to interference and dropouts.

I’ve noticed similar issues with my iPhone/KICKR 2017/Quarq setup. I’ve also experienced ERG mode resulting is sustained over/under target performance, and I’ve had to result to bumping the intensity up or down by up to 3% to hit the normal prescribed targets.

However, I can testify that the issues are significantly less pronounced running things in the easiest gearing. That said, the easiest gearing will also cause a loss of inertia in the flywheel. I personally like a bit more inertia to simulate a more real-world feel to the training.

As a result, I have now more or less given up on the ERG setting and have opted to take control myself via the resistance mode–particularly with longer interval sessions. Of course, the downfall of this means that I must stay much more in tuned with my power output and cadence to keep things on track. I’ve also noticed a bit of drift can creep in–e.g. 90 RPM may need to creep to 95 RPM at the same gearing and resistance to hold power as the trainer heats up. There’s also the opposing challenges of feeling strong and overshooting the targets, or lacking the mental toughness and undershooting.

But you can only have one connection, so it’s inherently limiting your options to one device and primarily an IOS device since Bluetooth Low Energy isn’t native to most Android devices or PCs. I believe you can find a dongle, but seems more fiddly than the ANT+ dongles.

All 3 of my sensors will broadcast simultaneously on ANT+ and Bluetooth (Wahoo Kickr, Stages PM, Wahoo TickrX HRM).

BLE isn’t native to most Android?! Maybe you mean older Android devices? Windows is the most fiddly of all you mentioned, although I understand from TR posts on this forum that Win10 allows better BLE support (and TR will be updating app to take advantage of that).