Wahoo Elemnt (+Bolt/Roam) Di2 Current Gear Display missing since latest firmware update

I spent hours yesterday swapping sensors between mine and my friends bike, it would work on his Wahoo but not mine. Now reading this its evident that he must not have updated his firmware :frowning: I can also confirm that factory reset didn’t work, and like someone else said taking screenshots of the display pages really helped.
Have submitted a ticket to Wahoo this morning, but surely its an easy fix by rolling back the firmware to a previous version until a proper fix can be found ???

That explains why when going through shift modes it appeared in the right gear but then stayed there when I went back to Full Sync mode. Luckily I’ve got oval Chainrings and don’t uses my bottom chainring very much, so will run it in manual mode until a fix becomes available. Thanks to everyone for their comments, I was pulling my hair out yesterday.

Top problem solving :slight_smile:

Same here

They fixed it. Checked first thing before my morning ride and my Roam downloaded a new version… and low and behold I have gear numbers again.

Now, if they could do one more update and give me a 1-0 gear for that killer hill leading to my house…

(Kind of like an Amplifier that goes to 11. )

Jim in Boulder


Yup. Good work, Wahoo. :smiley:

1 Like

I know they shouldn’t make mistakes like this but I know its not easy, certainly can’t fault them on their rapid response.

1 Like

Update! Gear display functioning in ALL modes! I checked my Elemnt Bolt today (I have D-Fly and the same gear display problems as others who have posted here) and it shows version WB15-8223, which is newer than the most recent shown on Wahoo’s website at

I ran a firmware update the night before last and gear display worked only in manual mode (got that partial hack from one of the posters in this thread). I just checked my Bolt a few minutes ago and confirmed gear display in manual, semi-synchro, and full synchro modes. So, sometime between two days ago and today, Wahoo has released a firmware update but its not listed on the website.


I wish Wahoo offered a way to save screens config to restore after a reset.

1 Like

I have now completed the latest update, but the same symptoms are repeating. Anyone with the same symptoms as me? I’m wahoo Roam user.

1 Like

I upgraded yesterday to the newest firmware and my DI2 gears are still not displayed either. I am using the ELEMNT Bolt.

1 Like

It didn’t work with my roam at first either.
After switching through all modes it works now. (M/S1/S2)

It seems to be working on my Bolt on the newest firmware (8223).

As usual, it takes ~15 seconds after the initial gear change in order for the Bolt to connect to the Di2 and display the gear number for the first time (change the display field from n/a to the actual number).

NB this is from a quick test of it in the house, not out on a ride, but hopefully the gear display remains as normal for the duration of the Bolt/Di2 connection being maintained.

1 Like