TrainerRoad with MyWhoosh

Can we maybe try to put together a FAQ here, listing the steps for using MyWhoosh with TrainerRoad simultaneously on a PC, and maybe on other devices? I’ve been using TrainerRoad and Zwift simultaneously for a few seasons by using two Ant+ dongles and letting TrainerRoad control resistance, while Zwift is paired with everything else. I’m bored with Zwift and don’t plan on renewing given the recently announced price increase. I think I can set up MyWhosh with TrainerRoad, but it seems more complicated because MyWhoosh doesn’t run in a window, etc. It could be really helpful to maybe put together a FAQ/tutorial with step-by-step instructions, because it seems a lot of folks here are also looking to dump Zwift.

Thanks all!

I have not used MW, but from their YT video, their pairing screen seems similar to Zwift.

Top center one appears to be the “Power” connection, while the bottom left appears to be “Control” which is similar to Z. I’d expect that using the “Tap to Disconnect” option on the bottom-left one will leave the trainer uncontrolled in MW, so you can use TR (or any other app/device) to control the trainer.

1 Like

Works flawlessly for me.
I use my remote app to control MyWhoosh and TR.

3 Likes

What is the remote app?

I wrote a few remotes for various apps.

One app with several remotes, I can switch seamlessly, much better IMO that various companion apps.

Fully customisable too, to suit your preferred setup.

I am using both at the same time.
The trainer is connected to Trainerroad, assioma power pedals are connected to MyWhoosh. It avoids any connection losses during training.

On Windows PC with Ant+ it connects exactly the same as ZWIFT.

The only thing i found is you need to connect your trainer to TR first or MW takes the ANT+ connection and it wont connect in TR
I found this strange as i have 2 ANT+ dongles so have 2 channels but i think that maybe one is switched off on my pc and i’m too lazy to go into the bios to check it

So first start TR and make sure its connected and then open MW and make sure Controllable is disconnected - It should work then.

MW will also connect via BT if your trainer has it which also seems to work fine but always make sure the controllable connection is off