TrainerRoad crash each time load workout

I’m using an old iPad, it used to work no problem. It’s on iOS10.3.4. I’ve tried deleting & reinstalling app. Done the latest update. Still goes black & crashes every time I load the workout.

Any advice??

Email support at They will be able to help you better then anyone on the forum as they can look at your logs

1 Like

Try to power cycle the iPad. Turn it off completely and turn it back on.

I’ve never had my iPad crash on TR but it sometimes does it on other apps that load a lot of data. It feels like some apps cause a memory leak and the iPad ends up out of memory. Once it happens, any apps start crashing randomly. Only thing that fixes it for some time for me is a complete reboot.

Fab, thank you!

Sadly, I’ve tried that a few times.

Same scenario as me. I think my iPad is too old to support the new TR updates.

I haven’t reached out to support because I just use my phone.

Let us know what you hear.

1 Like

I fear that’ll be the answer too but the App Store says only needs iOS 9 :woman_shrugging:t2:

Not just IOS, I’m running TR on a google phone 3 and have the same issue.

It might be lack of available memory. The solution then is to ensure that nothing else is running on the iPad and that you exit and close the TR app after each workout. These steps helped me get an extra two years out of my old iPad which couldn’t update past iOS9.