Strava or TR issue?

Not that it ‘really’ matters. But you know. 2mph is poor even by my standards :joy:

I calibrated before the workout and everything felt normal.

Are you using Virtual Speed in TR as pushed to Strava?

Burning 1900 calories in 5 miles. Now that could be a new diet fad.

1 Like

Yeah I tried going back and forward with it. It was more realistic using the other option. Not sure what I’m expecting, just more than 4 miles :joy: I’ll have to go do it again.

OK, not sure what setting was in place for the screenshots above. But it’s a bit interesting that the Strava pic is in Miles and about 1/10 what the other shot (is that TR or another app?) shows in Kilometers.

Makes me think there is something off in the conversion from TR to each of the apps.

Is your weight set correctly in TR and Strava?

Yeah that’s garmin & Strava screenshots. Both are a bit off from ‘normal’. The garmin one was the same as when I used the other setting in Activity Sync I.e it must use the estimated speed off the trainer.

Now nothing is syncing at all after I deleted it :upside_down_face:

I haven’t changed it. Can’t think what else it could be as the calibration went normal.

TR is the only one I know that does “Virtual Speed” as an estimation (and only when activated). The Garmin data will be purely the axle rotations x wheel size, where ever you set that. So that data should be reviewed, and then consider the gearing you are using that literally drives that end calculation.

Hey @OwenL !

I’m going to take a look into this for you. I’ll get back to you when I have a better idea of what might have caused this.

In the meantime, do you mind calrifying what you mean by this? What did you delete and what are you now trying to sync?

Also, is this the first time this has happened?


1 Like

Okay cool. Yeah I’d changed nothing, not sure what’s up. Not the end of the world but would be nice to sort :grin:


I did Chads suggestion and deleted it off Strava to then reupload after selecting/deselecting the virtual speed option. Then I went back to sync the activity to Strava from my account and it wouldn’t upload. It just keeps saying processing.

1 Like

I also tried to resync the ride from the app but it says it encountered an error and to try again. Which I did to no avail. I have the .fit file but not having it really there either.

1 Like

Do you mean that you’ve already tried to uplaod the ride file to Strava, and it was still inaccurate?

I downloaded the fit file from TrainerRoad and uploaded it to Strava, and it’s showing me a more accurate distance. Check out the screenshot below.

Yeah that looks like the file if I use the smart trainer data and not the virtual speed etc.

I’ll use this one and see how it uploads my next TR workout and go from there! Thanks

1 Like

It looks like your rides are syncing over again, as far I can see! Is everything working smoothly again for you?