PSA: DON"T Upgrade to the latest Beta - Breaks BLE on Mac (at least M1 based) [Resolved ✅ ]

PSA: I upgraded to the latest TR Mac Beta this morning, and it completely breaks BLE - see the below screenshot. I verified this on 2 M1 based Macs, and reported it to TR Support.


Same here on an Intel based Mac mini.

1 Like

I get that screen on a Intel based windows 11 machine, but is always sorted after a re-boot.

Thanks for reporting this, @alphadogcycling. The engineers are looking into this just now to get a fix out ASAP. Thanks for your patience, guys!



TR just released a hot fix / updated version of the Mac beta app that fixes the BLE issue - at least it fixed it for me.


Same here on the android app. Not good. All 3 BT connections dropped mid workout.

I had to leave the beta. Remove the app and install the current alpha? Version.

Hoping for an android fix too.

You should report the Android problem to TR support. I only reported the Mac issues, and it worked on the iOS for me this morning (but I didn’t check for an iOS update prior to my ride)

@AlphaDogCycling thanks for giving everyone the heads up!

Just to confirm, there’s a new beta release that fixes the BLE issue out now. To get the update, relaunch TR and you’ll see the banner at the top.

The new version is 2022.38.1.217 — you can confirm you’re on the updated version by checking the Support tab > scroll down > see version number (see image below).

@RolandGosebruch, let us know if you’re still running into issues after updating and we’ll get eyes on it ASAP.

@WombleHunter, @oldcyclist65, this issue only affected Mac beta (version Something else seems to be afoot so we’ll follow up in DM to get to the bottom of your cases.


Wow, that was fast!

Current version looks good. ANT+ and Bluetooth are on, all devices are detected.