Problem with a tacx neo 2 and cassette

Hi!
I have a problem with a tacx Neo 2. I am trying to put a 11 Speed cassette on it and either an Ultegra or a Sram force, once mounted and tightened with no spacers are… just lose.I tried to tighten more but I screwed the lockring…
Now, when I put the spacer (it is supposed to be mounted on a 10 speed cassette) before the cassette I can tighten correctly, bt I am not supposed to do it this way
.
any suggestion? where is my mistake?
thank you!
matteo

Hello Matteo.
Have you checked that you have all of the original spacers that were included with the cassette installed? I’ve made that mistake before and the outcome was similar to what you describe.
My Neo2 doesn’t need any special spacers for 11 speed Shimano. ( It actually does need the 1mm spacer that comes with the NEO 2).

hi! you mean the spacers between the cogs? in this case yes, everything is there. and on both cassettes there is no extra spacers before the cassette. I really do not understand.

Try this link.
https://tacxfaqx.com/knowledge-base/installing-the-cassette/

The bit that relates to you:
If your cassette has any indentation or recess at all, then you will ALSO need to install the spacer that came with your cassette. Unfortunately, this step is omitted in the documentation, and has led some Neo 2 owners to become frustrated while trying to install their cassettes.

HTH.

Hello Matteo,
I had the same problem as you I think with my new Neo2. Did you figure it out?

Cassette is Shimano CS-M9000 (11-40 tooth) 11 speed mountain bike cassette.
Lockring is the one that came with the cassette.
Tacx product is Neo 2T type T2875.

Problem is illustrated in these three videos:



Lloyd

11 speed MTB cassette is designed for a 8/9/10 speed hub. You need a 1.85mm spacer, in addition to any spacers that come with the CS-M9000.

People get confused all the time, thanks to the stupid industry. 11 speed MTB is just the old 8/9/10 speed hubs. The big cog is so big that they can arch it back, over the hub flanges, and since wheel spokes move away from the hub, they have plenty of room to add a gear without needing a new hub.

An 11 speed hub is 1.85mm longer than a 10 speed hub.

Edit: you’ve cross threaded your hub. When you screw something on, press in, and then turn it in the opposite direction of tighten. When it “drops” in, then you can tighten. That’s how you avoid cross threading. You can try to press in with the lockring tool, turn counterclockwise until you can feel the start of the threads, and then try to “fix” the cross threading problem.

Edit #2: Your driver is probably going to have problems even if you get it on correctly, due to the cross threading. Usually to repair it you would need to use a tap to clean up the threads. Anyhow, if you manage to get it on, take it off and put it back on multiple times and see if it cross threads again. Hopefully you’ll be OK, and just need to be more careful with that specific driver (or get a new driver).

From the SRAM service manual.

The hub on the Neo 2 is an 11 speed spline type.
Add the included 1mm (Tacx) spacer ring on the hub before fitting the cassette and it should work fine.

That’s what I thought too, as it’s the #1 user error, IME. Then I looked at the videos.

Look at the 2nd video. Somehow the threads are cross threaded. It’s going on crooked. I’d like to say it’s a machining issue, but most of the time cross threading is not a manufacturing issue. It could be the assembler screwed it up, or the purchaser did. Or it was a return, because the prior owner jacked it up.

Honor system, poster knows what’s up. If it’s Tacx, contact support and try to get a new driver. If not going that way and you need to buy a new driver, try and force it, but make sure it gets on straight. Tapping it would be a specialty tool, and I’ve not seen anything remotely like that any where.

1 Like

Yep. The video didn’t work the first time I tried it.
That’s cross threaded for sure. Almost like someone didn’t line up the 11t cog properly before tightening things.
Possibly a good case for XD hubs?
Being that it’s only a trainer hub, he can probably get it to work again if he gets it to screw in straight a few times.
On a bike I’d say it’s time for a new hub.

(My last comment was a follow up on the OP).

1 Like

Sorry to kind of hijack this thread. I spent a while fiddling around and came to the conclusion it must be something to do with the threads on the Tacx free hub. So I gradually moved the freehub around 360 degrees and was able to see a small but noticeable dent in the freehub that was preventing the lockring from being tightened. So now I know the problem I have to get Tacx/Garmin to ship a warranty replacement as this unit is brand new. Attached picture shows the problem.

2 Likes

@Matteo_Vitale . Take a couple of pictures of the cassette mounted to the freehub before you have put on the lockring and this will help others diagnose your problem. I agree you should not have to put a spacer to make this work - but I am not an expert.

Ouch! That’s a nice little dent.
(You could panel beat it while off the the trainer if you were in a pinch. A bit of dowel and a block of softwood should do it without damaging the threads).
Luckily the hub itself is really easy to swap out on the Neo. Glad you found the problem and it’s an easy fix.

Hi Matteo.
Did you ever get the 11 speed cassette installed without it being loose, and shifting correctly. I know that the instructions say not to use the 1mm spacer that came with the trainer, but without it, I can’t get the cassette to tighten up. When I use the 1mm spacer though, the cassette is tight, but there is a lot of gear jumping. Any thoughts on your experiences so far would be helpful. Thanks.

Which EXACT cassette do you have?

If you have:

  1. An 11-speed MTB cassette (that all are 10-speed sized, even for 11-speed gears), you DO need to use the typical 10-speed spacer.

  2. A newer 11-speed Road cassette that are based on the MTB standard (wider range like the 11-34 Shimano), you DO need to use the typical 10-speed spacer.

2 Likes

Matteo’s problem was a dented hub.

The instructions say to use the 1mm spacer, in addition to the spacer that comes with your cassette. It’s not entirely correct, and it’s confusing for many users.

  • If you took it off your bike, and your bike hub is 11 speed road, then you should transfer everything, including spacers.

  • If you took it off your bike and your bike hub is 10 speed road or MTB 11, then you will need to add a 1.8mm spacer (the 1mm spacer would work too, but you will need to adjust the derailleur trim as it won’t line up).

  • The Tacx Neo hub is an 11 speed road hub.

  • If you bought the cassette new, it might have included a spacer, if the cassette has a lip at the back. Use it. This is typically a 1mm spacer.

Here’s a chart I got from slow twitch. The 1mm spacer is called a 10-speed spacer. That’s what comes with the Tacx Neo. That is also what comes with some Shimano cassettes, that had a lip on it.

2 Likes

Hi iamholland,

Thanks for the response. I’m kind of out of ideas. I am using a Shimano 11-34T cassette (CS-HG800-11), and I bought the exact one that is on my Specialized Roubaix road bike for the trainer. When the back wheel is on the bike, everything works fine. The shifting is flawless. The cassette that I bought did come with spacer in the back already, and that is installed. I’ve checked, and double checked, that all of the engraved letters, and numbers, on all the cogs are facing me. When I put on the locking ring, I can feel the clicking as the notches on the locking ring, and the final cog lock together, but it just won’t tighten down enough to tighten all the cogs.

1 Like

Hi mcneese.chad

Thank you for the response. I have a Shimano 11-34t (CS-HG800-11) cassette. It’s the same on that is on my road bike.

1 Like

The problem was me!
I realized I was misplacing the 11 teeth cog, and it was not compacting the cassette. So it was working with the 1 mm ring but it wasn’t without. Then I put everything together properly and… no issues!

2 Likes

Same here. Check the position of the 11 cog

2 Likes

Oh, I have had no doubt that it was me from the beginning. I just couldn’t figure out where my mistake was, but that was it. My 11 cog was not positioned correctly, and wasn’t pushing against the rest of the cogs. I thank you Sir!

1 Like