Powermatch only reads one leg with L/R power?

Been using TR with my stages L/R and elite suito for a while (over a year) and suddenly today TR is cutting my power in half. It asks for 100W during warmup but says I’m only doing 50, or I do 200 and it says 100. Same setup worked fine 2 days ago.

I looked in the devices section and it displays the elite suito as reading correctly (200W), left side power reads as full power (200W) and right side reads right leg only (100W). Did something get swapped in powermatch so it’s only looking at my right leg thinking that’s both?

I checked firmware for suito and stages, was up to date, recalibrated, zero-offset’d, swapped both stages batteries. Restated TR a couple times and still same issue, and same numbers in the device section.

No clue where to go from here.

Batteries?

1 Like

After batteries, if the problem persists, an email to support@trainerroad.com could be worthwhile.

1 Like

Was there a firmware update? Some power meters have an option for sending over one (unified) or two channels and I wonder if that got toggled?

1 Like

Are you connected to the ID of the left or the right side?
The right side sends its data to the left, and is then added together. So you cannot connect the right side once it has paired to a head unit as it doesnt have an ant+ signal, presumably it still has a bluetooth so you can connect it to the app.

Try connecting to the left side if you havent already, and that should (hopefully) fix your problem

1 Like

Explained in post I check firmware for power meter and trainer

Explained in post I tried swapping batteries

Thanks!

Both sides were connected in the app. My phone only has Bluetooth, so I don’t think it was double connected but I will try only connecting the left side and see if it can still read right leg power.

Thanks. I’ll try a couple more things tonight and contact support if I can’t solve it.

I understand you checked right now, but i was wondering if it updated in the background recently that may have changed a setting. Sorry, I’m not familiar with your model’s update procedures.