Power2max powerbox crankset issue

Just curious to know if anybody else may have experienced the same issue.
I’ve had the power2max Powerbox crankset for quite a while and it’s never given me any issues. I also paid to unlock the Bluetooth feature. A while back their app updated and provided a free trial of the left right balance feature for 30 hours of riding, so I went ahead and did it.

Yesterday my crankset would not connect via Bluetooth, but I could still get ant+ connection. (I much prefer the Bluetooth so I can use my phone to train and my laptop for entertainment)

I suspect this coincided with the 30 hours of left right balance expiring, but I’m not completely positive because I don’t remember the exact day I activated that. Just curious if anyone else may have experienced the same thing. I did contact their support but haven’t heard anything back.

TL/DR- activated left right balance free trial on my crankset and at completion of that Bluetooth stopped working too.

Have you tried pulling the battery for a hard reboot?

Yeah, a pulled it for a few minutes, and then afterwords a couple of hours to no avail

I’ve already spoken with both power2max and FSA, not the type to just jump on a web forum and ask questions without thoroughly troubleshooting first. just trying to see if anybody else had the same issue and was able to resolve, or knew of another way to reset perhaps

Thanks. I did try the new battery and was able to talk to both companies- to no avail yet. I’ll try shorting it just to test it. I wish I could at least connect to the app, but ALL Bluetooth communication is completely shut off. :disappointed:

I can’t connect to my PowerBox PM from the P2M app anymore either (via Bluetooth, don’t have ANT+ on phone so can’t test that). Stopped working a few weeks ago I guess. I haven’t paid for any upgrades or anything like that so I’ve never used it with BT, just ANT+ to head unit. So maybe there’s an issue with the mobile app as well?

1 Like

did you check on P2Max websıte that if BT is still enabled?

Yes. It is. And either way it should connect via Bluetooth to the app, upgrade or not.

Interesting. Thanks… hoping it’s an issue like that.

interesting. My NGEco stopped connecting via BT just a couple of days ago. Never had any issues via BT. I’ve tried pulling the battery and putting that back in and that seems to work ok. Might try a new battery next time, but odd to see others are having issues with BT connectivity as well

1 Like

Are you on Android or iOS?

Hmmm. There goes my theory that it was due to an iOS update breaking the app.

1 Like

iOS as well

1 Like

iOS as well

It’s likely connecting to something else. Likely your app. BT only connects to one thing. Turn off your phone.

Yup, tried that right away.

Is it connected to the PC/Garmin? How far is the unit from whatever (more than 3ft)? Have you tried deleting the P2M, then reading? Is the BT profile on the P2M newer than your device?

IOS is making BT harder. Try looking at the app permissions, you might need to specifically enable notification and bluetooth (both). This is an Ios BT security thing.

Good idea on the permissions. Will check that. Proximity is definitely not an issue.

I’ve already insured it’s not connected to my PC, Garman, or anything else by taking the bike down the street out of range of anything else except my phone, and then did a hard reset by removing the battery to no avail

update for me. Changed to a new battery, which was odd as the TR app was still showing I had lot of battery life left. Then download the Power2Max app, and did a firmware update to the power meter. Between the new battery and firmware update, I am no longer having BT connection issues. Connects right away to TR app.


Update for me: I received an email back from Power2max in Germany finally. They have indicated that there is a glitch in many peoples iOS apps that has affected the connectability of the device. He suggested I borrow an android device and attempt to do a factory reset, along with making sure the Bluetooth was reactivated in the androidapp.

My friend brought over his phone and within five minutes it was fixed. So if anybody is having connection issues, grab an android device and see if that fixes the problem. Now it will connect to my iOS device without trouble as well