4iiii Precision fail!

Anyone having trouble with their 4iiii since the latest app update for iOS? It won’t allow me to use my credentials to login. It requires me to login via facebook. Once logged in, it prompted me to update the firmware. That process errored out and could not complete. So I removed the battery to reset it. It now does not connect with ANT or Bluetooth on my iphone, laptop or kindle fire. Customer service has been responsive but not able to provide me with a solution as of yet.

Thanks

I rode with mine yesterday, no problems but I use Android.

Yeah I was freaking out with this one too. I thought I’d bricked my power meter - it would connect over Bluetooth but not ant+ and wouldn’t report any data.
Sorry I see yours won’t connect over Bluetooth either! Try turning off Bluetooth on any device that previously could have been connecting to it. Then try the phone app again. Maybe also see if you can pair it under regular iPhone/Android Bluetooth devices

Once you have it talking to the 4iiii app.
Under device options - do a factory reset
Then try the firmware update again.
This was the only thing that worked for me

Hi Kev,

I see you emailed us and we sent out a few things to try. Did that resolve the issue?

Cheers,
Jerold

Thanks for the tips. Despite the battery last reading at 64%, a new battery was what fixed the issue. Glad to be back in action!

It would be nice if the iOS app would accept my password and ID. The android app allows login no problem.

I had a similar issue. Twice. I bought a 4iiii Precision in November of last year, and when the battery got to ~65%, it wouldn’t connect. So I swapped in the battery from my heart rate monitor. It read ~95% at the start, and was fine… until it got down to ~68%, then the same thing happened.

I have it my head now that 70% really means “replace the battery already”.

It took 50 hours for the first (new) battery to die, and 40 hours for the second. So overall, I don’t think the battery life is horrible (2032 batteries are cheap). But the reported strength is definitely a bit of a lie.

Still happy with my crank. I love training and riding with power. It was a gamechanger for me.

FYI… They released an iOS update today that fixes the login bug from the last update/revamp of the app.

1 Like

I had problems with my sworks power meters this week. Not sure if it was a 4iiii problem or Specialized. They sent a new left crank arm though. I updated firmware on my cranks using 4iii app. Now the Specialized crank app crashes every time I open it. :man_shrugging:t2:

Me too. Need to meet a pal for a long ride this morning. Thought I’d check the battery from my iPhone 4iiii app. For the first time ever it requires me to log in with a password. Huh? I tried Forgot Password, had to enter email twice. Still hasn’t sent me the email to reset. I see there’s an update, but can’t get into the app to update! I’ve really appreciated Precision’s stuff, but this is really a bummer. Don’t know why they tried to fix what wasn’t broken, or why they get Facebook into the mix!

I had a similar problem today with my left side powermeter. The update got stuck and I couldn’t get back to the factory settings and my Garmin edge 1000 couldn’t connect… I changed to a new battery but the App said 0% even though I knew there was 3,3 volts on the battery.

After contacting the 4iiii Support they gave me this procedure:

Turn the battery upside down in the pod and reinsert for 5 seconds in the powermeter - and then reinsert in the correct orientation. This will reset the powermeter.

Then try deleting the app and re-install - and then restart the phone.

That worked immediately for me - the new firmware is installed and I’m back in business!

Great and fast support!

Yeah ok. I had to send my left crank arm back to Specialized for replacement and I haven’t heard what the problem was, they just sent out a new arm. :man_shrugging:t2:

Seems almost every cycling item that uses a coin cell gets reset by putting the battery in backwards. Ive used it on cadence, speed, powermeters and heart rate straps. Fairly common.

With a recent update of its iOS app 4iiii forces you to create an account. (I imagine the Android app is the same.) That’s not cool. I wanted to calibrate my power meter before a ride just after the app was automatically updated — and couldn’t. And I am definitely not going to log in via FaceBook either, and feed the data kraken.

I wrote to customer support and let them know that their behavior was quite user hostile. To their credit, I received a prompt reply, they said they forwarded my feedback, but wouldn’t make any promises.

1 Like

I left a 1-star review for the same reason. I’m sure someone at 4iiii got promoted for the decision to force account logins, but… ughh, what a terrible user experience.

Yeah, that definitely sounds like some stupid decision pushed down from management. No, I don’t want 25 accounts, and no, you are not an alternative to Strava, TrainerRoad, TrainingPeaks, Garmin Connect and Wahoo, please don’t kid yourself. Just continue making good power meters. But as it stands now, when it will be time to upgrade my power meter, I will strongly consider moving away from 4iiii.

Actually the android app is very ummmm DUMB. Just options for calibration of the precision and viiiiva heart strap configuration and for reading sensors. Thats about all of it. Cannot log in or do anything that the fancy Iphone app can do.

Was a little jealous of all the extra features you all had. Not so much now.

And they still haven’t learnt. 10 minutes into my ride, go to calibrate, and damn I have to login - what damn login. And some other damn message saying that if you created if you created an account before 2.0 you need a new account. Luckily after my ride I could make some toast and coffee without downloading firmware and logging in.

1 Like

Unfortunately this happens with a lot of android apps. I cant understand why. But I as well had to update my app and create a new account and start over. Cant really tell much of a difference on android. The IOS app has always been much better! Android app that I use is garbage. I normally just use the garmin.

Interestingly, the Stages Gen 3 power meters seem to have the exact same problem.