Multiple power meters detected by TR app

Been struggling with my vector 3s
Power drops, thought I fixed it with baby oil
Today halfway through Palisades craps out. :imp::imp::imp:

Why does the app see 2 PMs? Usually they at least behave the same, today the battery levels are different but both no power, one had cadence.

I turned on my Garmin 520 and it actually worked, reading power so finished workout

One will be BT and the other ant+

If you look at the top you’ll see that you have both switched on and are connected to both. Just use one or the other not both. That’s where your problem lies.

1 Like

Should I choose ant or bt or let is auto pick

TR will try to use Bluetooth whenever possible, by default.

@mcneese.chad do you know if the showing of two separate devices (once as a BT and again as an Ant+ device) is normal, i.e. the default and always been like that? I can’t remember, but I think my pedals showed up as a single device before (with the BT and Ant+ icon together).

I have an unrelated (possibly related? :grinning:) recent issue with my Assioma Duo pedals.
link here: (Favero Assioma power "freezing")

Also the fact that the Ant+ device only shows cadence, and no power, similar to Original Poster above makes me wonder if this is related …

I think it depends on if you pick on the device. Meaning you probably picked on the BLE and ANT+ version, each at least once to make the initial pairing.

See this example. I cleared all devices on my Galaxy 9. See that there are 2 Neos, 1 for BLE and 1 for ANT+. And not that neither is paired, just available.

Then I pair the BLE version only.

Then I pair the ANT+ version next.

So, I think you can go in and forget both, or only the one you know you don’t want. After that, TR won’t grab it unless you actually pair it manually in the Devices screen.

Thanks for testing that … What’s different with mine (given I have some major other issues at the mo with the pedals) is the sporadic nature (sometimes the Ant+ device shows, but mostly it doesn’t) as well as the power numbers not showing (i.e. “–”) on the Ant+ device

1 Like