Missing Survey Response: a heads up

A quick heads up for those who are unaware.

There appears to be a bug in the software that prevents completed post-workout survey responses from being synched with and uploaded to users’ online workouts.

I complete all my workouts using the desktop app on my Windows 10 laptop, and always install the latest version of the app. For some time now, whenever I’ve gone to analyse my workouts online, I’ve noticed that the workout shows “Missing Response” - even when I’ve completed the post-workout survey in the app:


Whenever I’ve seen this, I’ve always updated my response online.

Checking through other users’ completed workouts in the “All Rides” tab of a workout, it appears that the vast majority of workouts have “Missing Response”.

I’ve been in touch with support about the matter and they’ve told me that “this is something that we are getting sporadic reports on and there isn’t a once and for all solution here just yet.”

When I asked if this in any way compromised the effectiveness of AT, the reply I received (over several emails) was: “So basically AT works based on your response to the surveys and your performance on each workout - therefore it is important to have the responses either via the app or via the web to help AT gather as much information as possible… When the survey response doesn’t show up on the web app, it’ll mean that the survey hasn’t been taken into consideration by the system. This will mean that Adaptive Training won’t work 100%.”

In other words, it looks like unless the survey response appears online - regardless of whether or not it was provided in the app - AT will not be as effective as it should be. With that in mind, after each workout it might be worth checking online to see if the response has synched properly and given AT all the info it needs to do its job.

I don’t know if this applies to apps other than the Windows desktop app - best to check for yourselves if you use Android, Apple, etc.


Have had this happen once or twice on the Android app. But not recently so it seems to be working fine now.

I’ve had syncing issues with the Windows App, including this, but I’ve found by leaving the app open longer before I quit, it doesn’t tend to happen anymore. Other times, closing the app and opening it again will cause any missed sync to happen.

Its maybe the quality (specifically lack of) of my Windows 10 laptop but I have only had a survey on it once sync to the phone/web, even though the work out does everytime, so I always check.

I also tend to often do rides outside or on other platforms and they definitely don’t automatically generate a survey so I am in the habit of completing a survey on the web anyway.

Yeah this is my challenge too - I wish it prompted for outdoor riders too.

1 Like

I run my workouts on an iPad (up to date iOS software) and complete the survey response on the iPad after every workout.

Not once has a survey response synched with my desktop App or the web based platform. I have to manually update each response.

It’s not a major issue but it is frustrating.


It happens pretty regularly to me on my iPad uploaded workouts.
I have also previously flagged to support

1 Like

With an Iphone I used to have this issue on most workouts. However, very recently the behavior changed – after filling out the survey on the app when I submit and it goes back to the WO summary it says missing response. But when I go to the desktop it shows my response.

It also happens regularly for me on my iphone


Same on Mac desktop app. Used to be okay, but hasn’t worked for the last month or so.

Thanks for reporting to support.

Any other athletes experiencing this should check in with support@trainerroad.com as well so we can better document and isolate what’s going on!

1 Like

I was having this problem aswell, latest update on Mac OS and seemed to resolved it. Haven’t had the issue in 6 workouts as before update it was everyone

Exact same thing here.

Have had this happen many times on the MacOS app.


Has happened to me too on my last two workouts.

Dont forget to check in with support@trainerroad.com as well so we can better document and isolate what’s going on!


same for me on an iphone.

I’ll send a message to support, but wanted to publicly chime in that this is happening for me as well, at least when using my iPad to run my workout. I’ve typically been doing that instead of using my Mac, but could test with my next workout.

1 Like

Thought I would share my experience lately and see if anyone else has noticed it. I’m using the Mac app on laptop.

The last 2 workouts before today, I would select the response and submit. I would then get the next screen where it shows my PL and instead of selecting “Close”, I would let it sit there while I went about putting things away, taking off my HR strap, etc. After I was ready to close out the app and shutdown my laptop, I would then select “Close” and shut everything down. The time waiting to shutdown was approxmiately 4-5 minutes. No “Missing Response” came up when I would bring up the website or iOS app later.

Today, I decided to experiment and just select “Close” right away. The response shows as updated in the Mac app before I close it and it looks fine (like previously). However, after bringing up the iOS app, there in all it’s glory was “Missing Response”. So, for me, the “hack” is to wait a few minutes before shutting everything off. Maybe there’s a delay getting to the TR server? I’ll try this approach again in the future and see if it works.

Just wanted to share and see if anyone else has noticed this kind of behavior. Cheers.

1 Like