Kickr Snap issue question

Hey gang. I’ve been a TrainerRoad user for the past few years, and have been on a KK “dumb” machine. For what it is, it’s been awesome, but recently upgraded to a Kickr Snap.

My first issue was my former FTP was 246, and after a two month break, I retested at 200. I then set my Snap up, and 180 watts felt like 250. I did both calibrations on it, to no avail. I did more troubleshooting, and I found my wheel circumference was set at 1100 and not at the correct 2096. I did that, and re-calibrated (after a 10-min warm-up). Note: this was on my Cervelo P3. This seemed to work, as my workouts have been doable. FWIW, I’m on the SSB V1. This was about 4 weeks ago. Fast forward to last night…

I pulled my Cervelo off, and put my cannondale CAAD8 on the Snap. I set tire pressure to 110 PSI, and the first thing I noticed was my trainer was louder than usual. I chalked this up to a different tire than my P3. Note: tire and roller were both cleaned up with simple green (simple green not sprayed directly on trainer roller). I did both calibration tests on it, and the calibration showed 6 sec and change. I tightened down a 1/2 turn (when placed on trainer, I had begun with 2 turns), and re-calibrated…same result. I tightened down another 1/2 turn, and got up to 9 sec and change. Although this was in spec, was still odd, as my P3 was on the upper end of 15-16 sec. okay, fine…time to workout. My trainer is loud, and now my erg mode isn’t working. Great. I went through the settings and made sure my erg was on. Check. Get back on bike, and erg mode not working. After 10 minutes, still nothing. I put my P3 back on, and everything works, but 180 still feels hard. Why would my erg work for my Cervelo and not the cannondale. I’m stumped. Any suggestions?

Sounds like something for kickr support

Have you done an advanced spin down?

In my opinion the Snap trainers are crap. Maybe you’ll be lucky and have one that works properly. I found the power was all over the place (compared to my 4iii power meter). I exchanged it and the replacement was just as bad. Ended up getting a refund and buying a Hammer. The Hammer is fairly close to my power meter. I now have a second power meter (Assioma Duo pedals) and both power meters agree almost watt for watt so it was definitely the Snap at fault.

Yea, I’m going to call them tomorrow

Getting closer. This thing works on Zwift. I’m at a loss here. It’s gotta be an issue with Trainer Road???

In sim mode, workout mode or both?

I’d recommend reaching out to our Support Team at support@trainerroad.com. They should be able to look into the log files to see what is going wrong :slight_smile:

In the meantime, I suggest updating your Kickr firmware if possible using the Wahoo Fitness App. This often resolves quirky communication issues.

Cheers!

This is now not working on anything in Zwift or TR. I’m in contact with Wahoo, and have a ticket open. I’m frustrated beyond belief with this product. I’m either going to send it back and upgrade, or send it back and wipe my hands clean if Wahoo, and revert to using my KK. I should have listened to the reviews on the snap. This is clearly my fault for throwing caution to the wind on this product

1 Like

@kbeers81 Kickr Snap user for a year with no issues.

  1. Make sure when you use TR that the Wahoo app is off and swiped away. Make sure no other 3 party apps are connected to your devices.

  2. Do all spindowns/calibrations inside of TR. Don’t use Wahoo app for anything other than updates.

  3. Make sure your Kickr Snap has the latest firmware update.

  4. Clean your wheel and roller with rubbing alcohol, Simple Green leaves a film.

  5. Pump the tire to the max limit (I recommend a trainer tire specifically).

  6. Hold the flywheel and pull down on the tire (towards the roller). It shouldn’t slip without significant force, like all your body weight pulling down. Then back it up a touch. You can actually back it up 1/8th turn after every ride until you feel/here slippage. Then tighten it a little and mark the location on the knob.

3 Likes

Thank you for your reply. I went into the wahoo app and attempted a workout on the erg mode, and still did not work. I will get some alcohol and try that instead. All third party apps have been shut down

update: I will first say this out of disclaimer/understanding for Wahoo: It’s a busy week for them. I get it. HOWEVER: They were helpful on day 1. The guy asked me to do a series of steps, attempt a workout on the Wahoo app, and then send him a zip file. He said once he received it, he’d be in contact with me. I followed his instructions, and the following day I called to verify he received it. The lady on the phone, who was an absolute delight (insert sarcasm) to deal with stated he would get back in contact with me when he has the time. I understood, as I’m not the only customer. Yesterday, I called back, and the lady said he was on the phone with another customer, and she would have him contact me via email so I can get the ball rolling on returning this thing. I woke up this AM, and didn’t receive an email from them, so I called again. The same “delightful” woman answered the phone, and I politely told her it’s time for me to return the product, and I’ll go w/ another company. She blew it off, and said, “No worries, I’ll get you an RTA for shipping.” Well, that was easy.

I hooked my kurt kinetic back up, and I gotta tell you guys, I like that thing. It’s old, and it works. The thing I like about the “dumb” trainer, is I can work to a higher capacity than ERG mode will allow. I was going to upgrade to the wheel-off machine, but for now, I’m content with what I have.

For individuals looking at the Snap, these were my issues:

  1. 180 Watts, a mere warm-up for me, felt like 300. I couldn’t figure out why. I looked into my settings, and I saw the wheel circumference was off by 1080 cm. Okay, I fixed that to the proper CM, and it appeared better, but my workouts were almost impossible. I then conducted my latest firmware update, and I hoped that was the fix to my problem, but clearly was not.

  2. I warmed machine up, and set the calibration. It first failed the calibration, so I wiped my roller and tire off, and attempted again. My calibration was at 18 seconds. I tightened down the knob a 1/4 turn, and attempted it again. It didn’t change much. I tightened it down 1/2 turn beyond that (2.75 turns now), and got it to just under 16 seconds. I did a calibration again, and then the advanced calibration, and the calibration was all over the place. I let it be, as at least I was in the ballpark, albeit the higher-end of the 9-16 seconds

  3. I attempted the ramp FTP test, and I was struggling at 160W!!! I hit 225, and it felt like I was pushing 350. Granted, I did not have a separate power meter, but I knew there was no way 160W would feel this difficult. At the end, TR advised me my new FTP was 165 (I have never been below 180, and this was 3 years ago). I train hard, and hit the gym frequently as well. NOTE: I’m headed to brother’s house tomorrow to hook up his power meter to my Giant Defy Advanced 1 to see how accurate old faithful, AKA Kurt Kintetic Road Machine is. This is my promise: If, for some reason, tomorrow indicates via an outside-sourced power meter, my fitness level has dropped from a false 246 to a legit 165, I will eat crow and will post that I suck at this sport; however, I highly doubt this is the case. I’m confident I will report to you guys that my KK is w/in the +/- 3 give or take.

  4. My biggest complaint: ERG mode worked sporadically, and then stopped working completely after 3 weeks of use. Things I did to fix this: Made sure all other third party devices were turned off. I made sure ERG mode was on. I wiped the tire clean and the roller wheel clean utilizing rubbing alcohol. I pumped said tire up to 110 PSI, and then I conducted both calibration tests on the Wahoo app, and then shut the app down, and then calibrated the machine via TR. I triple checked to make sure all other devices were turned off. I shut down the Wahoo APP and then turned on TR, and made sure the ERG mode was on. I couldn’t get ERG to work. I then shut my iPad off, turned my IOS phone on, and opened up the Wahoo APP, and did a workout via ERG on their app, hoping to see it would work, all to no avail. I then disconnected my bike from trainer, and took everything downstairs to try on the iMac, just to make sure it wasn’t an issue w/ my iPad and iPhone, and I got the same result. Okay, I’ve now done just about everything I could to troubleshoot this. I had high hopes for this product, because I really wanted the Snap to work for me, but it’s a faulty product. I could return it, and get a new unit, but I’m not impressed with Wahoo’s customer service. I will wait until black friday next year to start looking at other units, but for now, I’m happy w/ “old faithful.”

My advice, next time around buy a direct drive trainer. Any of the major brands are good.

I found Wahoo support to be appalling when I had dealing with them. Painfully slow to respond by email and not willing to accept that their product could be faulty. Trainerroad on the other are the gold standard on how to do customer support. They are heads and shoulders above anyone else and go the extra mile and then some to help their customers out.

3 Likes

TR has been a godsend to me. This has got to be the best training product I have ever used. I’m in no ways dogging Zwift, but after finding TR, I closed the Zwift account down. I think, for an amateur like myself, this is an above and beyond product.

1 Like

I was reading this thread and kept wondering when you or someone would bring up this point, I’m glad you’re already aware of this as a possibility.

As has been mentioned in other threads - the power number you get from a dumb trainer used without a power meter is not a ‘real’ power number. It should be consistent for training purposes and, assuming you are consistent with your trainer setup and tire pressure, be more than sufficient for you to train accurately and see great progress. BUT it is not a power number that you can use to compare to anyone else or any strain gauge based power number.

This isn’t to say that the Kickr Snap wasn’t also problematic (it sounds like the problems were greater than just inaccuracy but also included inconsistency) but there are tons of posts on this forum about people being very happy or very sad when they transitioned from virtual power to a power meter based FTP.

I hope, for your ego’s sake, that your FTP is actually higher than the dumb trainer has been telling you, but it is totally feasible that you have an FTP that is (significantly) lower than what your virtual power FTP has been for the past several years.

Won’t dig into the Kickr Snap stuff at all since you’ve already returned it, best of luck with your test on your brother’s bike

2 Likes

To be honest, I could care less what the number says. I just want consistency. If one machine says i’m lacking at 165W, but I can train to that consistency, and move up from there, is there really a difference to a machine telling me i’m at 300W w/ the same trouble? I definitely hear what you are saying, and I appreciate you bringing that up. I’m really curious to see what my KK tells me on the outside power meter. If this was the only issue w/ the Snap, I would keep it. My issue w/ getting rid of the snap is the ERG mode is simply not working, thus making it a basic fluid trainer. I think the advancements in technology is crazy, though!!! Much more than the faulty machine, which happens w/ any brand, is the lack of customer care.

To me it actually sounds like a communications problem between the device you are using to control the trainer and the trainer itself and not so much a defect in the trainer.

There are a number of steps you can take to troubleshoot this, including putting the controlling device on the ground next to the trainer, if using an ant+ dongle buying an extension cable to get it away from the laptop, changing WiFi settings on your house’s router (these can interfere), switching between ant+ and bluetooth, etc.

I don’t know which, if any, of these things you tried - but complete erg failures are almost always an inability for the controlling device and software to communicate with the trainer - usually due to distance from the device.

These issues are not Wahoo specific but instead vary based on your own setup.

Also - there’s a lot of ‘noise’ in your other posts about the other problems you were having that don’t appear to be related to the primary problem (ERG not working) - I would recommend you use the same rear wheel regardless of bike if you find yourself in a similar situation - would remove the PSI and noise differences you were seeing.

2 Likes

I’m glad you responded to me. I’m bringing both my trainers to my brothers house tomorrow. He’s a computer science engineer, so he understands faults a lot better than I do. I will have him read this thread. Thank you!

If you still have the Kickr Snap and want to run through exactly what device and applications you were trying there are a number of variables we can try to remove from the equation to see if we can figure out what exactly is causing the problems

1 Like

i’m all ears, my brother!

What device and applications are you using to control the trainer?