Kickr Snap experience, and query whether all Kickrs are the same (or is this a TR thing?)

I used a CycleOps PowerBeamPro for five years until TR sunset its support of that trainer with the switch to the new app. I switched to a Kickr Snap because of a variety of reasons.

post #1

It’s been fine, with a little bit of a learning curve. I actually thought it was better than my PBP for my slow-force reps that I did through base, and it was ok through sweet-spot work. I’m now entering into VO2max work, and found that the behavior of this trainer is bizarre. I’m curious if the behavior is similar for all Kickrs because I believe the issue is related to the control system rather than specific to the hardware. OR, maybe this is a new TR control thing, and not a trainer thing??

Normally I try to do anaerobic-capacity efforts (e.g. 30s on/1 min off, or other similar microbursty-type workouts) outside, but I ended up doing a workout indoors because of bad weather. The target was 130%, but I was supposed to go as hard as possible.
I should note that I did this workout in resistance mode, not erg mode. Typically this is better for microbursts, regardless, but I prefer this mode, generally speaking.
Observations:

  • During my warmup, I had a few 30s high cadence efforts, with an irrelevant power target of 80%. When I went to a power targets much higher (maybe closer to 100%, maybe a bit higher), I noticed that the trainer seemed to release resistance and power dropped pretty drastically, no matter how hard I pushed.
  • During the work intervals (6x[130% for 30s/easy for 1’]), if I went much harder than 130% for longer than a few seconds (say, 180% for 5-8s), the same thing happened. The trainer released resistance and power would drop, even though I was still going hard. When I bumped up the workout intensity from 100% to 105%, it seemed to be better.

I do not remember having this problem with my old PBP. It seems that this is a controls-system issue, where when the trainer sees that the power is above a certain percentage of target, it releases resistance.

Is this how all other Kickrs work??

As a separate comment, I had 3’ VO2max efforts of 120%, and found I needed to increase the resistance from 20% to more like 30% in order to hit appropriate power. I don’t know if other people need to do the same… I never really had to play with the resistance percentage with my old PBP unless I was doing slow force reps…

If I decide to change to a different trainer, I don’t want want get another Kickr (such as the core) if this is how they all behave…

Thanks for everyone’s thoughts.

Are you using ‘resistance’ or ‘standard’ mode. If it’s the former I think the snap will apply a linear power curve, like a magnetic trainer. Standard mode will apply a power curve, like a fluid trainer. You have different power curves to choose from. Maybe worth a look…

I will have to look again, but I think the only options I see when I go into the device settings are “erg” or “resistance”. I’m not sure that “standard” mode is an option… but that sounds like it would be better.

Standard mode should be available on Wahoo trainers, in TR, when connected via Bluetooth (BLE).

Ah… I will have to try to connect via BLE. I’ve been connecting via ANT+. I will give that a try! Thank you very much!!

1 Like

I’ve just checked my old kickr, I’ve got erg, resistance and standard, via Bluetooth on IOS. I’d expect that to be matched on all versions of TrainerRoad. The wahoo app will give you a rough guide of each power curve.

1 Like

I know you said you don’t like erg mode, but been using a snap for early 4 years and haven’t had this issue, even with microbursts (15 seconds or more are fine, the 5-8 sec ones are less than ideal). I DID have the issue you are saying at first, and was fixed with a firmware update (I was getting random releases like you are saying, in the middle of harder intervals).

1 Like

Thanks, @mcneese.chad and @NeilAllonby. I determined that I don’t have the right bluetooth on my TR laptop, and I had to order the right dongle. Unfortunately that dongle is now delayed shipping until 21 April because Amazon is prioritizing different products for shipment. So… I guess I’m stuck with this crappy response for now. I hope that Thursday will not be rainy and I can do my next microburst workout outside. If I really get desperate I’ll load TR onto my work laptop which should have the right version of bluetooth. But for now I’ll just survive. I’d rather not involve the work laptop with this sort of thing.

@llmonty unfortunately I’m up to date on firmware. Worth a thought, though. Thanks.

My experience too… my SNAP has been rock solid for over 3 years, no complaints at all.

Thats unfortunate. This is a long shot, I assume you’ve long since thought of this but do you have access to an ant+ dongle…? Or could you use your phone for trainerroad until that Bluetooth dongle shows up…?

I assume you meant this dongle by the way as your machine isn’t windows 10…? https://www.mouser.co.uk/ProductDetail/Silicon-Labs/BLED112-V1?qs=2bnkQPT%2BPaf%2BBQ6Sw8mJqQ%3D%3D

I have ant+, the problem is that I can’t get the “standard” mode unless I use Bluetooth. You are correct, my computer is NOT Win10. I could potentially use my phone for TR, or look to see if my tablet offers BT… I just prefer the larger screen of the computer. The tablet may not be a bad idea though…

And yes, that dongle in your other post is the one I was going to purchase. Interesting… I had looked at Digikey and Amazon, but not Mouser. Looks like maybe I could get the one from Mouser faster. Thanks!

1 Like

The tablet might be an option. Hopefully that dongle shows up soon. Mouser seem to be stating normal delivery times, so could be worth a look. Good luck. :+1:

Dongle arrived on Friday, and I finally had the chance to try it out today. After figuring out how to force the drivers to install (after first finding them on the Silicon Labs website… this was a bit of a PITA), it seems to all be functioning. TR recognizes the trainer via BT, and I get the “standard” mode. I’ll probably do my workout on Tuesday indoors and see if I get a better response from the trainer this way. I still think the trainer is going to “release” if I go too far above the target power, though maybe the feel will be better up to that point. Thanks for the help!

1 Like

Result re the dongle. You should have 9 resistance curves to choice from within standard mode, the ninth being the most severe. It should default to level two I believe however you could easily bump that up if needed. Good luck.

Reporting back. SOOOO much better in standard mode!! It felt like my old Cycleops PowerBeamPro. This was great. It defaulted to level 3, but I bumped it up to level 4 because it seemed to be better for my workout today. I didn’t have a lot of sprints today, so I didn’t test the “go way over the target power and it will release” issue, but for VO2max work this felt waaaayyyyy better. Thank you very, very much! Frustrating that I had to go to BT to get this mode, but at least I was able to solve it.

3 Likes

Brilliant, excellent news… glad I could help. :+1:

1 Like