Kickr core firmware update-failure anyone else getting this fault?


My new just out of the box kickr core is failing to go to firmware 1.06 from 1.02.

Has anyone else had this issue?

I’ve not had the best luck with wahoo support in the past.



1 Like

I’m not sure what troubleshooting steps you’ve tried but I would try these first

  • Keep the device you’re updating from as close to the KICKR as possible while updating
  • Make sure the Wahoo app is up to date
  • Reboot the mobile device you’re updating from
  • Try a different mobile device if possible

I would also check that the ANT+ ID and serial number match up between the app and what it says on the side of the KICKR.

I went from 1.0.4 to 1.0.6 without any update failures but i’m unsure about going from 1.0.2 directly to 1.0.6.

1 Like

Thanks. Seemed to be restarting Bluetooth has done it a treat.

You’ve got me into my session. Many thanks.

1 Like

I ran into this issue today. Couldn’t get the flash to work using my Google Pixel 2 no matter what I tried. As a last resort I dug out an old Amazon Kindle and the flash worked fine.

Reviving this thread a bit… For what it’s worth, my Pixel 3 XL would not update my 2018 kicker core after several attempts. It had the dreaded “update failure” message after every attempt. I pulled out my spare phone (Samsung galaxy s8) and it successfully performed the update to version 1.0.8. Cheers

I’ll pile on here, as well. I have a Google Pixel XL and I could not get it to flash the firmware despite several attempts, restarting my phone, unplugging and replugging in the Kickr. I even tried uninstalling and reinstalling the app to make it work to no avail.

My one saving grace was my iPad. Took literally 3 minutes to flash the firmware with it. Stupidly simple and problem-free. There must be an issue with the Android Wahoo Utility app and the current built of Android at the moment. I’ve put in a ticket with Wahoo, so if I get an update or solution, I’ll relay that here.

Cool, thanks for the info!

Replying to this thread with what I think is the answer to my problem: a bluetooth issue on my phone due to the RC Phone app.

Wahoo was unable to figure out the issue with this on their end, so I kept searching. I started to notice that whenever I would connect to a bluetooth device (like my car or a speaker) that my phone would start a phone call with itself. Took me a few weeks of googling to see if others had the problem, and then I learned it was due to the RC Phone app, which I use for work. Since deleting it (the new RingCentral app replaced it), I have had no issues with bluetooth.

Not sure this is the cause for everybody’ else’s problem, but figured I’d share in the event y’all also have that app on your phone.

Adding on as well since this thread solved my issue. I have a Google Pixel 3, was able to add the Kickr Core to the Wahoo app and attempted to Update Firmware (1.0.6 ->1.0.10) and it kept failing. I used my older Samsung Tab S tablet and it worked perfectly. Looks like there is an issue with Pixel devices trying when attempting to update firmware.

1 Like

Pixel 2 failed for me too, Samsung Tab s5e worked a charm.

my nokia 6.1 won’t upgrade the firmware either, i’m guessing the same problem

don’t have any other devices to try :upside_down_face:

I have the same issue with the Android app on my Pixel 2 XL. I always have to update the firmware using my iPad.

Got a new kickr core and also could not update on my One Plus 5T or the Pixel 2 my wife owns. Had to use an old tablet and that worked fine. Also can’t register the core via the Android app. Read that more people have that issue and it should work fine on an iPhone.

Similar issue here: just got a new kickr core and cannot update firmware or register the core using the Wahoo Fitness or Wahoo Utility app on my or my wife’s Pixel 2. Haven’t had a chance to try on a different device yet.


tried the wahoo fitness app rather than the utilities app and it managed to update first time!



Ditto. New Core would not update with pixel 3xl. Worked first time from my Android tablet though.

WELP, got my new Core in the mail today, and using my Pixel 2, the update fails every time. It’s already sitting on the Core, and I can’t find the firmware update tool in the Fitness app (just the Utility.)

Any resolution here? Not a great start Wahoo.

check this:

Yeah, that’s what I was following. It goes through the process then says failed.

I’d pick up the phone and call Wahoo (and hope tech support is working from home).

Make sure you did this before picking up the phone:

If the update fails, restart the process by fully closing and reopening the Wahoo Utility app. You may also need to reboot the KICKR itself by disconnecting the power for 30 seconds, then reconnecting it.