Issue with Wahoo Kickr Snap

Hi, y’all…

Was doing Tunnabora yesterday and had an issue where I couldn’t get to the target power (ERG mode, small ring, which had worked on all previous workouts to hit the same target). I paused the workout, exited the app, and did a spindown through the Wahoo app. Firmware is up-to-date and tire pressure was 110psi (trainer-specific tire). When I got back into the TR app it was a little easier to get to the power target, but ultimately I had to shift to the big ring to really hit the workout.

What am I doing wrong?! Thanks!!

I searched and found your ride. You appear to be using a Stages power meter along with the Snap (per the info at the bottom of the Power Zones section). This adds complexity to the situation and needs some clarity.

  • Are you using the TrainerRoad Power Match feature or the Wahoo Power Match option?

  • What are you using to capture your cadence? It looks rather up and down in the workout.

    • Erratic or constantly changing cadence is a bad thing for ERG to handle. It is trying to hold a power with a set resistance, but can only do that well with consistent and steady cadence.

    • Here is my workout from earlier this year. I am not using a separate power meter, just the trainer power.

    • There is still variation, but see how my cadence is a bit more steady. This workout is a tricky one, since the instructional text also talks about making cadence changes. Not sure if you tried to follow those, but it is a complication compared to others where you just aim to hold one cadence for the block.

    • My setup is one step easier for the entire system since it is reading and adjusting the same device (trainer). Power match with a trainer and power meter adds time and fluctuation to most workouts. It requires an especially smooth and steady cadence to prevent the hunting for power/resistance that may be present in your deal.

  • For your ERG workouts, are you trying to watch and control the Power value, or are you focusing on the cadence? I find that people who watch the power, tend to “chase the power” and try to help the system hit the target. This only causes problems. If you watch power, ignore it now, and focus on hitting your desired cadence only. Hold it steady and let the app and trainer control the resistance to hit the power target.

1 Like

Thank you for that detailed response!

First, I don’t know what TR Power Match and Wahoo Power Match are… when I first connected all my peripherals to TR (on an iPhone) it either recommedned or asked if I wanted the Stages PM to be the power source (or just cadence)… I chose power and cadence. For my previous 5 or 6 workouts since I started I don’t believe I experienced the issue I had yesterday…

I was focusing on cadence, not chasing power… it was only when the trainer didn’t catch up with me that I realized there was an issue.

1 Like

Also, if I were to change to the trainer providing the power and resistance, and let the PM just handle cadence, I assume I would want to do another ramp test, correct?

Thanks!!

Here is the TR PM info:

Per your process, you are using the “automatic” setting with PowerMatch, anytime you have your trainer and power meter paired in TrainerRoad Devices.

Yup, they are likely to give different power, so a retest if you choose to ditch the Power Meter data (and just use it for cadence), is the best plan.

1 Like

Thank you, Chad!

What is your recommendation? As I had stated, I’m using a Kickr Snap, specific trainer tire, and a Stages PM…

Skimming through your recent history, it looks like your cadence is a bit variable to me.



These are both steady interval, but your cadence never settles in Antelope, and is a bit better but still more up and down in Carson. This leads to greater and more frequent power fluctuations, especially with PowerMatch in use. Without changing your setup, I’d try extra hard to hit flat and steady cadence and see if that helps at all.

If not, you can try some short tests with the power meter as cadence only, and see how it works for you, to remove PowerMatch from the equation.

1 Like

Chiming in on the Power Match thing. I have a Stages PM and used a Snap for about 18 months. I found that that the Power Match feature in the Wahoo app (Tap your device> “Control w/ ANT+ Power Meter”) was a much better/more accurate method of having both consistent power indoors and out, as well as getting a better response from TR and the Snap.

You can actually use it in conjunction with TR’s Power Match feature, but I found that to be unnecessary.

2 Likes

Thank you!

I’m at work today (FF), but will be home tomorrow and have another workout… I’ll try this option first and see how it goes. To confirm, to do this I switch PowerMatch to “dsiable” in the TR app?

1 Like

Nah, just enable the Wahoo feature, then set your Stages to “Cadence Only” in TR, which will automatically disable TR’s Power Match feature. It’s a little convoluted.

Also, doing this you shouldn’t need to re-test since the actual power source isn’t changing. But use your best judgement—if workouts seems too hard or easy, then something likely needs to be adjusted.

3 Likes

Summerson - WOW!! This worked so much better than the other way! This should be the default option… Thanks again!

2 Likes

Awesome. I found that to be the sweet spot for me too (no pun intended) and carried it over when I got my Kickr Core. Glad it worked as well for you!

1 Like