Issue with app not recognizing login info

Thank you for your work and reply. Despite my frustration, I love the product and appreciate your help tonight I’m getting us back in the saddle. Pun very much intended.

We all know the only right thing for for Trainerroad to do is give us credit for a breakthrough workout and give us all an automatic 10% increase in AI FTP. I would also accept @Jonathan handing me off a “cold” Maurten hydration pack at Leadville.


Finally able to log back in but now the workout I just finished is completely missing.

Yup, someone on the TR team said it won’t be processed until they resolve the issue.

Thank you for the update and everything you and your team does. You have my fullest sympathies for the Friday night code fix. :pray:

Here’s what we think is going on.

Our transaction log in our Azure database is full and not letting us write to our database.

We aren’t able to clear this ourselves so we’re waiting for Microsoft to answer our ticket and clear it for us.

Right now we’re trying to deploy a change to let everyone log in. You’ll still be able to do rides and they will sync once everything is fixed.

We have a 1 hour SLA between Microsoft and ourselves for these types of outages. I believe we’re about 90 minutes over and I think (hope) that our engineers are now talking with them to get it fixed.

Sorry everyone!! We’re not sure what caused this but we’ll look into it so it doesn’t happen again.


Thank you Nate, I’m still unable to login, but it sounds like whatever you’re saying your amending may not be fully done yet?

You should now be able to log into the app. Rides won’t sync and process yet, but you should be able to train and your ride will be recorded.


Try now. Just went up


TBH this kind of a response on a Friday night is better than I would expect from 99% of any other service I use. Thanks TrainerRoad, keep up the great work!


hmm, you might just have the wrong password. I believe the error you would see is “unexpected error” if it was the issue we just had.

Anyone else able to login?


I can log in, but it looks like my workout is gone. I tried refreshing on my phone app and it shows the scheduled ride, but as not complete. On my tablet where the workout was completed, it shows as not having anything scheduled for today. Both devices are Android.


iOS types it for me. I can try resetting it, but that gave an error also.

Able to log in now. My completed ride from earlier today is not showing but you went over that already.

1 Like

I can log in on windows and android now.

Thank you!

1 Like

Your rides should all be there when this is fixed. Worst case, if for some reason the server didn’t like it, you have a local log file that we can use to recover the ride.


@Nate_Pearson We appreciate the quick response and ongoing updates. Your team is awesome. Also, it’s great to know the workouts aren’t lost.

1 Like

not only that… i completed a major ( for me) 2hr workout and at the end when I finished it tossed it away as if I never did!! i f’ng furious .

then the login issues started,

1 Like

Was able to log in on the mobile app but not desktop. Also on the mobile app tried to update calendar and move today’s ride to Saturday, but received the message “Request failed with status code 500”
Thanks for all your help TR crew