Interval Countdown Audio and Video Not Synced

This is a minor but annoying issue. TR support has not been able to figure out what’s going on and suggested reaching out to the forum.

During the 3 sec interval countdown, my audio beeps are delayed by 1 sec relative to the onscreen timer display. So, the audio starts a 2 sec to go and the last beep is 1 sec in to the new interval. The beeps are occurring when they should…but just with a delayed start.

This does not happen on my very old Dell Latitude running Windows 10, but only happens on my new Dell XPS 17 9710. The new laptop is running Windows 11, the processor is a 11th Gen Intel(R) Core™ i9-11900H @ 2.50GHz, 2496 Mhz, 8 Core(s), 16 Logical Processor(s), has 32 GBytes of physical memory and a NVIDIA GeForce RTX 3060 Laptop GPU. So plenty of horsepower.

With support, we’ve tried reinstalling TR, deleting some TR folders, disconnecting my HDMI connection to the TV, stopped running FulGaz and even tried testing with the latest TR beta…but nothing has resolved the issue.

Anyone have any ideas on what might be going on or things I can try to fix this.


Running audio through bluetooth? Like headphones or speakers?

Nope…just the laptop speakers…or via HDMI if TV is connected to laptop.

I was having audio delays with Trainer Road, 20-30 seconds. I found the issue is not with TR, but with the audio drivers. I went into the sound settings and found that playback of the test sound was also delayed. This might not be the same issue you are seeing, but I see you are also on a Dell, so could be the same thing. I found the following link, which so far looks to be working.

I hope that’s the fix for you!


Wait…there is audio to TR? Who knew?


Beep… Boop… Beep


Thanks. Support had me disable three settings in the Sound control panel and the sync issue was fixed. I owe support some testing to see if we can isolate which setting or combination was the cause.

The fact that they kept working on it when we suspected that it was a computer issue and not a TR issue is a credit to the TR support team.

Do you remember which three settings you disabled? I’m having similar issues with a laptop I just started using for TR. Thanks in advance!

Hey, @Ted_Boone! I was able to dig up those steps.
Theres a chance there’s a day delay specific to your Windows computer that we can help you check for and fix. To see if there are any obvious delays, you should be able to confirm through following the steps below.

  1. Click the Windows logo on your keyboard and type in “Control Panel,” then click enter.
  2. Navigate to “Hardware & Sound” then to “Sound.”
  3. Click on your computer speakers and select “Configure.”
  4. When you select “Test,” the speaker icons will show a visual that should be in sync with the audio that is produced.
    If these are out of sync, then it’s possible that your speakers and display have gotten out of sync for your new laptop, which isn’t noticeable for most sounds.

If the audio is off when you run this test, then we may be able to fix this by navigating back to your computer speakers and selecting “Properties.”
From here, open the “Advanced” tab and try unchecking everything except the “Exclusive Mode” to see if that fixes the delay you were experiencing.

Let me know if you see a delay there and if it works!

Just to follow-on what Ivy posted, I didn’t have much luck doing the “Test”, but disabling everything except “Exclusive Mode” worked.

I must have done some additional testing, because it appears that the only feature that really needs to be disabled is the “Enable audio enhancements” selection. At least, for me, that is the only one I have disabled at the moment and I don’t have any audio delay.