Garmins rebooting during rides lately?

Has anyone else had their Garmin freezing and rebooting a lot recently? I wonder if it wasn’t a firmware update.

I haven’t had any issues with it until the last few months.

I just did a ride on Sunday with an Edge 1040 on the latest FW without incident.

Which Garmin and what FW version?

All fine here with a mix of 530/830/1040 Plus, etc. Most of them in the beta firmware program.

Two things to check:

  • Free space on the unit. (If you’re on a Mac be sure to also clear trash after deleting files).
  • Do a full sync with Garmin Express via USB.

Had the same recently too. Thanks @GPLama for the ideas!


530, and I have no idea. I just installed it a few weeks ago.

One time it froze and crashed around the time I entered a segment.

Another time I lost power data for several hours, then the unit crashed, and then it came back.

I will see if I’ve filled up the memory somehow!


I’ve had my 830 since it was released and it’s been pretty solid.

However, first ride after the most recent update I had the unit reboot during a ride.

Impressively when it booted back up it had not lost my ride and the route I was following was still loaded.

On the portion of the ride prior to the reboot I did think that the unit was sluggish, it took a while to find all my sensors and a GPS lock and route guidence was hit and miss.

After the reboot it was absolutely fine again for the rest of the ride which was approximately 2 hours and has been fine for my last 3 rides.

Hopefully it was just a one off after the update? Maybe the update left a load of junk in the memory? Don’t know.

Shame if they have introduced a bug because over the last few years Garmins updates have been very good - I don’t get “the fear” I used to have when it was time to update my software on my old edge 1000.

1 Like

So, I just learned I still had every ride I had done since I bought the unit in August 2021 stored on the unit…

Apparently you have to delete them manually.


Come to think of it, my old Bryton also acted weird when I had a lot of stored rides….

1 Like

A buddy had his 1030 plus reboot mid race last week.

I use a 530 and haven’t had an issue with it rebooting but during my last race the warning about an upcoming turn got stuck on the screen for a while and I couldn’t move between screens and was worried it was frozen. I pressed the lap button and it worked so I just tried to not pay attention to it and it eventually went away. It could have been a problem with the route but it definitely bugged me during an event.

I did check to see if my old activities were still on there and they are, should we manually delete them? I’ve still got +4gb free.

My 830 works fine except occasionally (especially on the weekend while scouting BWR) the gps would play up mid-ride. Two things would happen while using a loaded route. Map and climbs would still be loaded but the directions would stop, the map arrow would stop updating, and the distance to go would go to zero. I had to reboot the route three times during the ride to get turn directions again. I pray to god that doesn’t happen mid race.

The other thing, happening is climbpro would start either minutes before or after the climb.ended. Pretty off putting when you’re on climbs upwards of 12% not knowing if it’s about to get a lot worse or not. :joy:

Were your ears (or fingers burning) typing that!? See the other thread I just exhumed. :rofl:

Commented on that thread. Also this link articulates The issues I’m experiencing better.

1 Like

I see the “route calculation error” fairly consistently when deviating from a course since I’ve owned the 1040 back near launch date and updating software regularly. I have GPS set to “most accurate” and I’m riding in Los Angeles, where roads are not new, but there can be lots of road work that forces detours. After a couple of route calculation errors, my 1040 rebooted on a few recent rides. I’ve updated to the newest firmware that’s public release, not beta.

1 Like

I have seen that several times in the past few weeks.

This is most likely an n=1 thing, but I had nothing but issues with my Garmins (530 then 1040). The 530 would reboot mid-ride for basically no reason. The 1040 would end rides without my input - especially in the rain (touchscreen). It would also just randomly stop the turn-by-turn directions.

I switched to the ROAM v2 and I’m happy except for losing the Garmin Training Effect. Wish I could’ve stayed in the Garmin ecosystem as I have a Fenix watch.

Another N=1, but I actually had terrible problems with my Roam dropping me and refusing to get me back on my route. It ruined a couple of rides where I ended up getting lost and about 2 years ago I went back to Garmin. I hadn’t had any problems at all with the newer Garmins (mine is a 1030) until just recently, where it has rebooted on me mid ride a couple times. Oddly, when it comes back, it’s like nothing happened and just continues me on my route.

1 Like