Garmin speed sensor 2

Ok, I sifted through all the threads and didn’t find the answer. Just today after the recent TR app update my sensors don’t show my power. Battery and signal are both strong, just no power number. Worked fine the other day before the update? I re entered my virtual power trainer model again with no luck. Any suggestions? Thanks.

Which OS are you using? I’m on Android with the latest updates and use a Garmin speed sensor 2. Everything worked this morning.

For sure to reach out to support! They’re pros with device connectivity. :sunglasses:
support@trainerroad.com

IOS…weird that it’s worked fine until now.

Will do thanks.

try resetting the speed sensor as well. Take out the battery and short the positive and negative battery terminals. That’ll drain any capacitors on the power rails and completely power off the unit. Then reinsert the battery.

You can short the terminals by flipping the CR2032 battery over and putting it in. The large head on the positive side of the battery will connect the terminals (short).

Awesome thanks I’ll try that.