Fulgaz (AppleTV) and Traineroad (Android)

I’m looking for an alternative to Zwift and trying Fulgaz. I’ve used Trainerroad and Zwift for years without any problem. Traineroad controls my trainer and I run Zwift on an AppleTV (receiving power only, no control) - CABLE. It works like a charm.
Trying same setup with Fulgaz, control trainer is disabled, but every 45s or so, the resistance drops.

Does anyone have tried simular setup above? Run into any problem?

Thank you,

Hello @kairalla :slight_smile:

Let’s have you follow this process to see if it works!:

First, you will need to pair your trainer to TrainerRoad via ANT+ and FulGaz via Bluetooth in order to pair it to both apps at the same time.

To ensure that TrainerRoad is the only app controlling your trainer, follow these steps:

  1. Open the FulGaz app and click on the cog icon in the top right corner of the screen, then scroll down and select Advanced Trainer Settings.
  2. Enable Passive Mode. If you don’t see the Passive Mode option, select Separate Power Meter Support.

If you don’t see either of the above options, follow these steps instead:

  1. Launch the FulGaz app.
  2. Connect your trainer as a Power Meter rather than a trainer resistance controller.

Let me know how it goes!

1 Like

Thank you for the information.
I don’t have the options passive mode nor separate power meter.
When I connect to the trainer, I choose the power only. There is an option called “Trainer Resistance Control”, which I leave blank.

Not sure what else can be done. It seems Fulgaz can’t work in “passive mode", just receiving power as input without controlling the trainer.


Hey @kairalla :slight_smile:

Just to double check, did you connect your trainer as a Power Meter rather than a trainer resistance controller?

If you can also attach screenshots of what you are seeing that would be great!


Yes, I’m connecting it as power meter. The option to control the trainer is not selected.
See picture attached (PowerON, CadenceON and TrainerResistanceOFF).

Interestingly enough, even though trainer resistance is not selected, Fulgaz still says “Connected - Select to use” (see on TrainerResistanceOFF).

With this configuration, the power keeps dropping every 40s or so.

I use the exact same setup with Zwift and it works perfectly.


1 Like

Hey @kairalla,

I had a look at some backend data from your rides to see if I could figure out what might be going on. I think it would be a good idea to check that you aren’t pairing your trainer to TrainerRoad twice; via Bluetooth and ANT+?

You can check your trainer is only paired once from the Devices tab in TrainerRoad.

To ensure you aren’t double- pairing, you could try turning Bluetooth off on the device you are using to run TrainerRoad (until we solve the issue). The ANT+ protocol allows a single sensor to be connected to multiple devices at the same time, so you could try connecting the trainer to both apps via ANT+?

Let’s also run through some basic troubleshooting steps:

  1. Close out of all other apps running on the device you use for TrainerRoad.
    This will help to ensure that other apps aren’t interfering with your connection.

  2. Restart your device.

  3. Delete and Reinstall your TrainerRoad app.

You can find the latest available version of TrainerRoad in the link provided below:
TrainerRoad App Download

Let us know how you get on after trying those steps!

1 Like