ERG Mode accuracy

I just picked up a 2017 Kickr and I have been surprised by how far outside of the target it goes in ERG mode both above and below. I have the latest firmware and have done the spin down and advanced spin down and still the numbers seem to vary more than I expected. I know there have been reports of issues since the latest TrainerRoad update and I am not sure if that’s what I am seeing since I got the trainer after the update and have no reference point for normal operation.
So I guess I am wondering what % of the target or how many what’s is typical variation in ERG mode?

Best to try on mobile via BLE to find out (you don’t specify device or protocol you are using right now, but your comments parallel experience on PC with ANT+).

I have the Kickr connected via BLE to my Mac laptop but I am using an ANT+ powermeter for power match (Vector 2s). Sorry, forgot to include that in the original post.

1 Like

PowerMatch is another variable that can/will affect results. You could do a short test without it to see if that single change does something for you.

I will give it a try tomorrow for a short ride and see what just using the powermeter in the trainer does. Thanks for the suggestion.

1 Like

Can you post a screenshot of a TR workout? It’s probably normal behavior, but maybe not. When I first got the Kickr 2017 (direct drive, wheel off) it defaulted to reporting power that looked nearly perfect (but was a lie).

For some reason Wahoo decided against reporting raw power, and made me believe I was doing “nearly perfect power” but it’s not true. You can toggle off smoothing in the Wahoo app. Or toggle on and make believe you can ride at perfect power targets.

1 Like

This is yesterdays ride. I’ve never had the kick smooth the power since I had power match on. Perhaps it’s normal but I could hold it this close easily on a “dumb” trainer. The three short one-minute intervals were supposed to be 260, 265 and 270 but instead averaged at 262, 258 and 257. They actually got easier than harder. But my biggest concern was the third 5-minute interval at 270. I averaged 271 which isn’t too bad but at one point I was at 255 at a cadence of 90 and 4 seconds later I’m at 311 at the same cadence. It seems I can be 20-30 watts over or under frequently which ends up feeling more like over under then a steady state.

1 Like

power zones are ranges, and I personally wouldn’t be concerned. That chart looks normal. You may be able to reduce power swings by using little chainring, and focusing on smooth pedal stroke. My personal opinion is that focusing on obtaining exact targets isn’t worth time or effort. Others may feel differently. A few thoughts below:

Those are openers, I wouldn’t be concerned.

  1. Power zones attempt to map a continuous range of physiological/metabolical responses to a discrete set of 7 power zones. There is overlap. Your estimated ftp may not map exactly to maximum lactate steady state, the basis for the zones. You can and should adjust ftp and/or interval intensity if it doesn’t feel right.
  2. Your body is unlikely responding (much) to temporary excursions like hitting 311 for a second and then dropping back down.
  3. Riding outside has a more dynamic (“stochastic”) power graph.

Estimates and more estimates, and then hoping for exact compliance to a single power target (270 vs 271) seems odd when you stop and think about it. Others will disagree, I’m just being practical and focused on primary benefit of working different energy systems (“fuel mix”) and strength endurance (sweet spot) or aerobic endurance (vo2max intervals).


Thanks for the input. I guess my big concern is that I am not having technical issues. My lack of experience with erg mode and numerous posts about issues lately have me questioning whether or not my set up is performing the way it should. My expectation wasn’t perfection but certainly a tighter compliance than 41w above target.

I am going to try a short ride without power match today (as suggested by Chad) just to see if the compliance is any better or not. I will report back with what I find.

1 Like

you should see better compliance with PowerMatch turned off, at least I do with Kickr 2017 (wheel off, direct drive), Stages LR power meter, and something like 53x17 gearing. However I can’t really feel the difference between Kickr power and PowerMatch, really feel about the same. And the 40W deltas are very short lived.

1 Like

For reference, a workout on my H2 (trainer data, not power meter data).

For reference, a workout on my Kickr17 (trainer data, not power meter data).

30t Front Chainring x 17t Rear Cog

1 Like

small chainring, right?

1 Like

Yes, good point. I will add that above.

1 Like

I have been using the small chainring as well and about middle of the cassette. I tried using just the trainer with power match turned off for just the warm up of the same ride as I already posted. And I turned off power smoothing in the Wahoo app. It looked much better to me although I would get a bit high on the beginning of the interval depending upon how hard I tried to get up to power.


Based on collecting data from Stages (total L+R) w/o PowerMatch, I tend to think either a) Wahoo is a little aggressive smoothing out the raw data from optical sensor, or b) its the difference between measuring power at crank arms vs trainer due to drive train and internal trainer losses.

Not really sure what’s going on, but based on feeling alone I prefer the big chainring and recognize its easy to over-analyze / over-think things.

The best first step when tackling issues like this would be to make sure your firmware is up-to-date on both your KICKR and your power-meter. Then, you will want to make sure to calibrate both, for the most accurate results. Fresh and/ or fully charged batteries will also help.

At this point, you may want reset the trainer by unplugging it for about 30 seconds to a minute, before plugging it back in. Then, do an Factory Spindown one more time. That should help ensure that your KICKR is reading accurately.

Lastly, there are a few practices with the trainer that may be useful here:

  • Use a lower gear on your trainer, little ring in front at least
  • Try reducing your cadence slightly before the interval starts. That should help the trainer build a little resistance before it has to really pile it on. Hopefully that will reduce that over-shoot.
  • If all else fails, try disabling PowerMatch in TR, and setting your KICKR to be “Controlled by ANT+ Device” in the settings of your Wahoo App.

I hope that helps! If you would like one of our support agents to look into this issue for you, please submit a support request to and we would be happy to take care of you!

1 Like

Thanks for the suggestions Tucker. I do have the latest firmware update on the trainer. I will double check my power meter though. Also I have been using the small chainring and around mid cassette for gearing.
The reduction in cadence is a good tip as well. I noticed that helped a bit yesterday when I was checking with power match turned off in TR.

One question I have though is that if I have power match turned off in TR but Controlled by ANT+ device in Wahoo app do I still essentially get power match when using TR? It gets a bit confusing as to which app or both I should be setting things up in.

I am happy to help!

You are correct though. If you have your power-meter set to control your trainer in the Wahoo App, then it is essentially the same as PowerMatch in TR.

That being said, you do not need both running at the same time either.

I have had both running on my initial ride where I encountered the issue. Could both being on be causing an issue?


It seems that the power-meter and trainer should be sending the same data. Although, due to the constant relay that PowerMatch requires, it could be that running the two systems concurrently was leading to reduced performance of either feature.

1 Like