Eagle AXS Download Help

I have just tried to install the new download in my eagle axs derailers, and for both of them, they would only get to about halfway and then disconnect. They still think they are getting a download so they won’t shift at all. I was wondering if anyone here has any idea on how to do a factory reset or fix this issue?

I would first unpair/forget the devices (shifter and derailleur) from your phone app. Then unpair the derailleur from the shifter. Then take the battery out of the derailleur and shifter. Close the app and swipe away to ensure it’s actually closed. Restart your phone. Wait a couple minutes then install the batteries. Make sure your batteries have enough charge (green lights turn on). Turn on your phone, open the app, repair everything and try again. This is essentially a “hard reset” of all devices involved.


It worked first try, thank you so muchh


How do you unpair the derailleur from the shifter? Cheers

In the SRAM AXS app. I believe if you click on the part their should be an option. If the part is not showing up then it’s not paired to the phone. I don’t know of any method to unpair the controller/shifter to the derailleur (remove batteries from both maybe), I would assume by pairing it with a new counterpart.

Thanks. The rear derailleur was doing funky things and wouldn’t work. Tried doing what you said and on the 3rd time it worked. Thanks.

1 Like