Di2 Connection Issues

Hi all,

I have recently upgraded from Dura Ace 9100 to Dura Ace Di2 9150 - installation went well and the system is all working as it should. However, I do not have the wireless unit so have been trying to plug the system into my computer via the EW-RS910 to however the system just will not connect or show on the E-Tube app. Has anyone else had this issue? I have tried it on multiple computers and none of them show the Di2 system connected.

Has anyone else had this issue and overcome it?



Are you using Mac or Windows?

Windows - tried on 2 different laptops.

You might try getting in touch with Terry at https://di2center.com/.

He also posts over at https://www.bikeforums.net/. Not sure if he is a member here.

1 Like

I don’t know if this will make you worry more or worry less, but not surprised. I’ve bricked my DI2 a few times trying to connect to it through either the computer or the wireless. It seems very particular.

That’s interesting. I’ve taken it to a shop and they have ran a diagnostic on it and updated everything saying the system is now fine - but they cant test chargers. I’m going to give another charger a go and see if that works.

What charger are you using? You listed the junction box, but I believe there is more than 1 type of charger. I know I have had issues with the USB being used with the charger may be power only and not data. Try a different micro-usb cable if you are using the SM-BCR2 charger.

I have the SM-BCR2 charger - I have tried two micro usb cables but perhaps they were both charge only. Thanks for this I will try get a micro usb data cable (Y)

1 Like

If you have a garmin or wahoo computer the cable that comes with the devices should be a data cable.


You might try getting in touch with Terry at https://di2center.com/ .

Thanks - I’m everywhere these days :wink: (well, I tend to show up wherever people mention “Di2”.

Like bpm1055 said, I would also try a couple of different USB cables. Especially since you’ve tried running e-tube on multiple computers already. Normally you connect the SM-BCR2 to the bike, run e-tube, select ‘road’ and then click ‘connection check’.

Still, if it doesn’t work, what does it do exactly? Does it get past the “Connect the SM-PCE1 / SM-PCE02 / SM-BCR2” screen at all? (or just it just look for the SM-BCR2 until you click ‘Exit’?)

Also… does your EW-RS910 charge port work? Have you charged the bike before using the EW-RS910 and the SM-BCR2?
The shop probably used the SM-PCE1 / 02 - those plug into an e-tube port instead of the junction A port.

1 Like

I think you mean crash. Bricking is when the hardware is basically useless without the SM-PCE02 device or sending back to shimano as the firmware written to the device went bad. Crashing means if you pull the connection to the battery and plug it back in everything starts to work again.

It does happen - sometimes people send me emails after having trying to update (and failing for some reason) using the SM-BCR2. It doesn’t happen all that often, as far as I can tell - but it does happen. The wireless/BluetoothLE updates are especially bad though… fortunately 99% of the time those are just crashes.

I have (intentionally) bricked an R8050 front derailleur by unplugging it at the start of a firmware update.
(wanted to test my SM-PCE02)

I guess the way I read that was it bricked just connecting (i.e. not only during an update)

Don’t know why you’d ever want to wirelessly update firmware. Updating my bike in the middle of a ride far away from the computer never seemed like something I’d want to do.

Okay, I will try some different cables. I have only had the system a few weeks, I have charged it with the SM-BCR2 and had no issues at all, they only start (or dont start) when I plug it into the computer.

In terms of what it does - I plug it in, open the software, select road and it then pops up telling me to “Connect the SM-PCE1 / SM-PCE02 / SM-BCR2”.

You’re right - the shop went straight into an e-tube port - for a second I thought I was plugging it in wrong!

Thanks for your reply, much appreciated.

1 Like

You can restore your own firmware by connecting the charger to a computer and resetting the firmware yourself.


I/They use the term brick to describe an unresponsive system. Whether it is technically bricked is just semantics. Bricking would normally mean there was no way to fix it even if sent back to someone with a special tool, but whatever.

1 Like

I just connected my SM-BCR2 to my laptop and ran E-Tube Project.
Even without being connected to the bike, it should do this:

  • Plug SM-BCR2 into USB port
  • Click ‘Connection check’ (E-Tube)
  • It’ll display “connect the SM-PCE1 / SM-PCE02 / SM-BCR2”
  • It detects the SM-BCR2
  • after ~15 seconds it displays the next screen, asking you to connect the BCR2 to the bike and to click ‘next’.

So if it doesn’t get past the ‘connect the SM-PCE1 / SM-PCE02 / SM-BCR2’ stage then your problem is either with the BCR2 or the USB cable. (or the computer, but you tried two different machines)

Thanks - I have ordered a new micro usb data cable. If this doesnt work then I will try a friends charger.

Thanks again for your help.

Hi @terry_bettershifting - I just tried a new micro usb data cable and boom - we have lift off.

Thanks again for your help.