Desktop App failing every single update

Have been dealing with this for months now, have worked with TR support over and over and there is no resolution so trying to see if this is widespread or not so they can fix it. Basically when an update is released the green bar comes up on top and says app will update on next launch, but it never does. Hitting “restart now” simply shuts down the app and does not install the update either, giving the same green bar on the next launch.

TR has had me delete temporary data folders, other folders, a combination, had me delete and reinstall TR entirely, and nothing has worked. With the most recent attempt, after launching the app for the very first time and completing a workout, I get the same exact green bar, so it now seems like I have to un-install and completely wipe every trace of TR for every update, (I last did this on 1/18 for my ramp test, had off 1/19 when an update was released, today on 1/20 it failed to update again). This does not impact the functionality of the product but just a constant reminder that the software is not right and its really annoying that I have gone through 4 or so of these rounds over the last few months.

Running on iMac with Big Sur…anyone else have this issue with Mac or maybe even PC?

1 Like

It wouldn’t surprise me if this is an Apple bug. Their software quality has really gone downhill the last few years.

Do you have any other user accounts on the computer? It might be something related to permissions.

And there are some really weird MacOS bugs that are often fixed with an SMC or PRAM reset.

I don’t have any issues with zwift updates which are also plentiful. A bit weary of doing any kind of resets of anything since I remote connect to my work computer through a program called Citrix (which also gets plentiful updates) and I don’t want to chance goofing that up.

My Mac works OK. I’m running the latest Big Sur. I don’t use Citrix though.

Maybe go through the syslog and console logs to see if there are any messages about TrainerRoad.

Have you tried deleting ~/Library/Caches/com.trainerroad.*?

Updates may be some sort of permission thing.

They had me delete the Application Support folder, then the Saved Application state folder, and the entire TR program, then empty recycle bin. Maybe a step worth checking next time with the cache

So they actually sent me an email after the third of fourth fail to delete the cache folder, and it is now updating by itself

1 Like